readers can't leave comments at posts

  • Author
  • #853248


    Readers can’t leave comments at posts with their e-mails in the last days

    The blog I need help with is



    Yes, the email requirements have changed. In order to use an email address that is known to WordPress or Gravatar, it is now necessary to login to prove it is not being used by someone else. Email addresses not known to either should still work as usual, or no email at all, if allowed by the blog admin.

    There are already a few threads on this issue, including a long one titled “You must be logged in to comment”.


    Here is the long thread that @motre mentioned: .

    You can go to settings > discussion and set your site not to require an email address or name and that should make it so that anyone can comment, even with a wordpress or gravatar related email address.



    Provided the content of your blog content is not “mature” in nature and only for “adults” will you please consider linking your blog to your username? That way we can click and locate it instantly. Dashboard -> Users -> Personal Settings -> then scroll down to Account Details. Then scroll down to where it says ‘Primary Blog‘ select the URL for your primary blog and then save changes.

    Please see here >
    and here >



    This is so frustrating. The old rule of ‘if it ain’t broke, don’t fix it’ seems apt right now. As it is, folks who comment on my blog have to re-think what they do. The only thing that seems to work now is for them to NOT put in an email address. That way they get around the Gravatar/Wordpress email issue.

    Annoying for those who comment and aren’t aware. As it is, I have to educate my friends how to log-in.

The topic ‘readers can't leave comments at posts’ is closed to new replies.