Recent comments widget — what creates the line breaks?

  • Author
    Posts
  • #709566

    windwhistle
    Member

    I’m using The Morning After theme and have the Recent Comments widget on my front page. Some of the comments run the width of the column and end there. That’s what I’d expect. But some of the other comments run on to a second line where they display just two letters and then stop. Shouldn’t all comments run the same length? I can’t figure out what’s causing them to end in different places or I’d try to adjust it in CSS. Is there a fix? Having some comments showing only two letters in a second line looks really odd.

    The blog I need help with is piedtype.com.

    #709753

    I checked http://piedtype.com/ and I couldn’t see any recent comments widget there or any of the widgets where comments run onto a second line with just two letters. I think that could happen depending on the comment length and if the two letters were a word like “on” or “at” or something similar.

    Could you point us to a specific example where we can see the problem happening or take a screenshot when you see it happens so we can see what you are seeing?
    http://en.support.wordpress.com/make-a-screenshot/

    #709764

    windwhistle
    Member

    It’s on the front page of my blog at http://piedtype.com. Center column, below the poll. It’s titled “Afterwords.”

    #709765

    timethief
    Member

    Perhaps the title length is a factor. The comments I see that have a second line are all on posts that have long titles.

    #709767

    windwhistle
    Member

    But wouldn’t it truncate all long titles at the same place (right margin), instead of letting some run to the next line? I tried counting characters, but that doesn’t seem consistent either. It seems to me there must be a parameter somewhere telling those titles where to stop, if not at the margin.

    #709768

    Aha, I should have seen that. The extra spacing is coming from the 16x16px avatar size you set for the recent comments widget. The length of the comment author name and the heading also affects it. It looks like The Morning After theme is designed to try to fit each comment on one line when no avatars are present, but when you introduce avatars of different sizes, then you change the dynamic a little.

    #709772

    You can try something like this to adjust it the way you want with your 16x16px avatar size setting:

    td.recentcommentstexttop, td.recentcommentstextend {
    height: 18px !important;
    display: block;
    overflow: hidden;
    }

    You won’t get the ellipsis character at the end of each item, but it should tighten them up to one line each while keeping the avatars.

    #709796

    windwhistle
    Member

    Thank you. It does indeed tighten each comment up to one line. I’ll have to decide if I like that without the ellipses. Looks a little odd.

    I’ve always liked the touch of color that the avatars add, but I just realized if I opt out of using avatars, this theme puts in special comment icons and includes the entire post title. Cool. I think I’ll do that. But thanks for your help, designsimply. I wouldn’t have figured this out otherwise.

    #709797

    Looks good. :)

The topic ‘Recent comments widget — what creates the line breaks?’ is closed to new replies.