Recent Problem With Embedding An Excel Spreadsheet From SkyDrive

  • Author
  • #1017383

    I recently starting having a problem when I try to embed an Excel Spreadsheet into my Word Press Blog.

    I have done this many many times, so I am very familiar with the procedure.

    What is happening now is that when I paste the Embed Code into the Word Press text editor then click “Save Draft”, the Embed Code that I pasted disappears rather than compile into shotcode. It just vanishes.

    I know what is supposed to happen is that the iframe code should be automatically converted into a shortcode, but that is not occurring.

    I have tried this on both Firefox and IE and have found the same issue.

    Additionally, I have attempted to repeat this process using existing embedded Excel spreadsheets that I know are working on older posts, but I find the same problem whenever I attempt to create a new one.

    If anyone has any insight it would be greatly appreciated.

    Thank you in advance.

    The embedded code I am pasting is as follows:

    <iframe width=”402″ height=”346″ frameborder=”0″ scrolling=”no” src=”’GMS_RUNNING_TALLY’!A1&wdHideGridlines=True&wdHideHeaders=True&wdDownloadButton=True”></iframe>

    The blog I need help with is



    iFrame codes and Javascript are restricted codes and will be stripped out to preserve security and stability on this muti-user blogging platform..



    Hi and thank you for getting back to me so quickly.

    Is this new?

    I have embedded Excel spreadsheets from SkyDrive many many times. Right now on our blog there are dozens.



    Really! Well then forget my advice and I’ll flag this thread for a Staff response.


    Thank you again for being so helpful.

    Can you tell me how long it usually takes for a Staff response?



    Just a minute now. I responded as if you were referring to a free hosted blog like

    If you were referring to then its not a free hosted blog and you need to post to

    For clarity read: vs. The Differences


    Hi Again,

    I am talking about our Blog site


    Found the following when searching around and I believe this is the problem I am having.

    Can you shed an insight on this?

    Thanks you in advance.


    Hi, you may already know about this but just giving you a heads up in case you don’t.

    Microsoft are changing Office Live documents in SkyDrive to resemble the Metro interface, they have also started offering you the option to opt in to a preview of the new Office Web Apps. I currently embed spreadsheets into my WordPress site.

    I decided to opt in and then found that any new items I went to embed simply didn’t appear. I noticed that the url Microsoft provide you with for the preview has changed and no longer starts, but starts and I think WordPress doesn’t know yet how to interpret it.

    Giving you the heads up in case this becomes a wholesale change and all of a sudden WordPress user’s can no longer embed documents/spread sheets etc.



    ***** I FIGURED THIS OUT *****

    For any Microsoft Live Office SkyDrive Users you need to turn off the option to “opt in” to the new version of this application.

    Once you do that, the embed code that gets generated works fine with

    I assume that sooner or later Microsoft Live will be migrating completely to this new version so is going to need to address the change in how Microsoft is generating their IFRAME embed code.




    as Microsoft Live Office SkyDrive User I’m having the same problem to generate the right code to embed. Could you please let me know where should I turn off the “OPT IN” option ? I’m not able to find it !
    Many thanks



    I was having an operational xl application at null.
    since I needed to modify it, I generated new code at skydrive.But when tried to embed the same at , Iwas horrified to find that the existing xl calculator could not be embedded by leaving my users in lurch.
    I also find that the new code from skydrive was starting with src=” …….” instead of the earlier code starting with…’ I feel that only on account of this I am unable to embed my calculator and other applications also that I intend to use in
    Having searched the whole of internet I did neither find an alternative nor a solution to my problem.
    What I am supposed to do in the circumstances other than leaving



    As per my understanding problem is due to new office web apps.
    I found this workaround :
    Go to SkyDrive Option and there you need to find Office Beta Option
    Select “No Thanks” option, meaning that you don’t want use new office web apps.
    After this ,the code is generated when you embed Excel, is the same you had in the past.
    Hope it helps.



    Hi Everyone,

    Apologies about the delay here, and thank you for your patience. We’ve fixed up the Skydrive shortcode here on

    The instructions on how to do the embeds has been slightly modified, so I’ve updated the Excel, and PowerPoint instructions and added instructions for Word .

    Both the old links/format and the new format will continue to work, though I suspect that Microsoft has already started deprecating the old format on their end

    Hope that helps and please let us know if there’s anything else we can do.



    Thanks all staff /jkudish
    now it works as earlier and no need to remove ‘s ‘of https:
    I have tried it with excel.
    thanks again



    Thanks but !
    I works only if you embed a sheet without selecting a cell range and/or without selecting a specific cell to start.
    Waiting for your help



    Hi bravob,

    I’ve tried embedding just a cell range and it has worked fine for me. Can you please copy/paste the embed code that you are trying to paste into so that we can further troubleshoot. You can use to paste the snippet of code and then share the link here.




    Thank you
    here it is :




    Hi bravobob,

    The code you pasted is working fine for me when I try to embed it. Are you following the instructions here?

    If you’re still having issues, can you please specify which blog you’re trying to embed this in?



    Hi JKudish,
    thanks for your prompt reply. I’ve tested it again many times.
    While yesterday I was ready to say : “sorry it does not work” (page was blank without any Excel), today, before wasting your time, I tested it again and it works !
    Don’t ask me why. I suspect there was either a latency retriving the Excel web app or Microsoft webapp server to slow in response time. Waiting for few more seconds and it appears !
    Thank you !

The topic ‘Recent Problem With Embedding An Excel Spreadsheet From SkyDrive’ is closed to new replies.