Redirect loop, what soluce ?

  • Author
    Posts
  • #1731431

    Hello

    First : my registrar is gandi.net

    At start, i setting my DNS on gandi.net with NS1, NS2 and NS3.WORDPRESS.COM.
    Good redirect but problem, my contact form on wordpress.com doesn’t send mail to my webmail on gandi.net.

    Back on gandi.net, restore default settings and modify DNS on wordpress.com with some help found here :

    EN > https://wiki.gandi.net/en/domains/management/wordpress#using_gandimail_with_wordpress_dns
    FR > https://wiki.gandi.net/fr/domains/management/wordpress#utiliser_gandimail_avec_les_dns_wordpress

    Now, i have this setting :

    A:  optique-salengro.fr géré par WordPress.com
    NS: optique-salengro.fr géré par WordPress.com
    CNAME: *.optique-salengro.fr géré par WordPress.com
    MX: optique-salengro.fr	 mail handled by spool.mail.gandi.net. with priority 10
    MX: optique-salengro.fr	 mail handled by fb.mail.gandi.net. with priority 50
    CNAME: imap.optique-salengro.fr	 alias de access.mail.gandi.net.
    CNAME : pop.optique-salengro.fr	 alias de access.mail.gandi.net.
    CNAME : smtp.optique-salengro.fr	 alias de relay.mail.gandi.net.
    CNAME	 webmail.optique-salengro.fr	 alias de agent.mail.gandi.net.

    But my website is out with redirect loop.
    Can you help me for soluce this ?

    Thank’s a lot.

    The blog I need help with is optique-salengro.fr.

    #1731519

    raincoaster
    Member

    So is the problem with the domain leading to the blog, or with the email? Here are some useful links

    http://en.support.wordpress.com/domains/

    http://en.support.wordpress.com/email-forwarding/

    #1731624

    The email forward is ok since last change, but the blog redirect loop between both url
    http://optiquesalengro.wordpresss.com
    http://optique-salengro.fr

    Thank for your help

    #1731626

    timethief
    Member

    Although optique-salengro.fr has been registered, it is not using WordPress.com nameservers. If your domain is mapped to a self-hosted site, then your configuration may be fine as currently set up.

    If you wish to host your site at WordPress.com, you will need to update your nameservers as outlined below.
    http://en.support.wordpress.com/domain-mapping/map-existing-domain/#instructions-for-mapping-an-existing-domain
    If you’re not sure whether you own this domain or not, the WHOIS database record may help you out.

    #1731627

    raincoaster
    Member

    I’m not at all sure that a hyphen works on a WOrdpress.com blog, actually. That may be the problem.

    How long has it been since the domain mapping?

    #1731628

    timethief
    Member

    We require that your name server configuration include only the following servers or their numeric equivalents:

    NS1.WORDPRESS.COM
    NS2.WORDPRESS.COM
    NS3.WORDPRESS.COM

    Your name servers are as follows:

    B.DNS.GANDI.NET
    A.DNS.GANDI.NET
    C.DNS.GANDI.NET

    If you have access to change the nameservers for this domain, please remove all nameservers not on the required list above.

    A DNS lookup for your blog returns the following information:

    ; <<>> DiG 9.8.4-rpz2+rl005.12-P1 <<>> NS optique-salengro.fr
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 45268
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 3

    ;; QUESTION SECTION:
    ;optique-salengro.fr. IN NS

    ;; ANSWER SECTION:
    optique-salengro.fr. 10800 IN NS a.dns.gandi.net.
    optique-salengro.fr. 10800 IN NS c.dns.gandi.net.
    optique-salengro.fr. 10800 IN NS b.dns.gandi.net.

    ;; ADDITIONAL SECTION:
    c.dns.gandi.net. 171713 IN A 217.70.182.20
    b.dns.gandi.net. 171713 IN A 217.70.184.40
    a.dns.gandi.net. 171713 IN A 173.246.97.2

    ;; Query time: 146 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Thu Apr 3 20:29:51 2014
    ;; MSG SIZE rcvd: 146

    #1731651

    Ok, i changed DNS in ns1, ns2 and ns3.wordpress.com.
    I wait effects because the redirect loop is always effective.

    #1731661

    rootjosh
    Staff

    I am seeing http://optique-salengro.fr/ point correctly to your WordPress.com site.

    It can take 24-48 hours for domain/DNS changes to propagate throughout the internet. It typically happens faster than that, but it really depends on your ISPs update frequency. If you are still not seeing the correct site appear after 48 hours has elapsed, please contact me again.

    Also, do let me know if you have further questions or if anything is unclear.

    #1731683

    It’s ok.
    With setting NS1, NS2, NS3 on Gandi.net and this settings for mail on WordPress.com :
    https://wiki.gandi.net/fr/domains/management/wordpress#utiliser_gandimail_avec_les_dns_wordpress

    … all functions works perfectly.

    Thanks a lot at all

    #1731689

    rootjosh
    Staff

    Great to hear!

The topic ‘Redirect loop, what soluce ?’ is closed to new replies.