Redirection on WordPress Website.

  • Author
    Posts
  • #3241401

    pk228470
    Member

    I’m trying to redirect HTTP to HTTPS but it’s not working.

    Actually recently I updated my website with SSL certificate in that everything is done. I have added redirect code in my .htaccess file.

    RewriteEngine On RewriteCond %{HTTPS} off RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301] But the only Homepage working perfectly.

    It’s automatically redirecting http://www.lyricsfed.com to https://www.lyricsfed.com

    But all others page/post did not get redirecting. I am using your plugin, please give me a solution for all page redirecting.

    I want to redirect my all post automatically.

    Example: http://www.example.com/post/ to https://www.example.com/post/

    Pleases short out my problem.

    #3241916

    Hello,

    Sorry, your experience these issues! I found a solution that might help you with what you’re experiencing

    Please go here:

    https://en.support.wordpress.com/https-ssl/

    Hopefully, this points you in the right diorection>

    Happy New Year

    #3241919

    Note that you’re posting in the support forum for free sites hosted at WordPress.com. The support document provided above only applies to sites hosted here. You’ll need to reach out to your host directly or:
    https://wordpress.org/support/
    https://en.support.wordpress.com/com-vs-org/

    #3241922

    arvindsinghu
    Member

    Hi @pk228470,

    Your site http://www.lyricsfed.com is using the self-hosted version of WordPress, and you need to seek help at the WordPress.org forums:

    https://wordpress.org/support/forums/

    These forums are for WordPress.com hosted sites only :)

    I can check you are using free SSL certificate of a CDN CloudFlare, and you already have an option to enforce it on all the pages of your WordPress website.

    Go to Crypto, and you can see an SSL option there.
    If you scroll down, you can see an option always to use HTTPS, enable it.
    Or you can use search and replace plugin to obliterate HTTP links from your database. If you have access to your database, then go to phpMyAdmin and run this script

    UPDATEwp_postsSET guid = replace(guid, 'http://www.lyricsfed.com','https://www.lyricsfed.com');

    If you still face the same issue then check this article How to Fix Mixed Content Error After Installing SSL

    Thanks !!!

The topic ‘Redirection on WordPress Website.’ is closed to new replies.