Need help? Check out our Support site, then

Remote Images Won't Load

  1. I discovered this morning that a URL like this:

    Will not load an image from The link breaks.

    If, however, I move the image file and load it like this:

    The image loads.

    It seems doesn't like the "/" folder -- is it because it's a second level directory call or because of the dot in the directory name?

    (Note: Don't try to load those URLs on your own because they won't due to hotlink protection, but I can set up a live example on one of my blogs if that would help support.)

    The blog I need help with is

  2. Doesn't that all happen browser client side? The browser requests the image and includes the web page it's in (this is where your hotlinking protection fits in). My guess would something needs adjusting with your hotlinking protection.

  3. Hi Lloyd!

    It all worked just fine on calling images via Movable Type.

    All other image calls from my server into worked just fine -- except the one example with the dot in the directory name.

  4. Strange brew.

    Have you tried temporarily disabling your hotlink protection and see if still the case?

    Maybe it got munged in the import. Maybe, something that needs all the technical details, and might be a better discussion over email support.

  5. Hi Lloyd!

    My .htaccess hotlink support is done via domain name -- so as far as my server is concerned, the domain(s) and my pointed domain(s) are all approved.

    It's that doesn't want to load the image from my server in edit view or published view. If I move the image from the dot sub-directory, to the main domain directory, it loads fine. Non-dotted sub-directories work just fine with successfully pulling the image.

    I suppose this is more a wonderment than a lingering problem -- I solved it by copying the wanted files out of the dot sub-directory and moving them to the main directory and re-coding the image calls -- and I'll mark this as resolved.

    Thank you!

Topic Closed

This topic has been closed to new replies.

About this Topic