Remove Date Time Stamp on mobile version of Nishita

  • Author
    Posts
  • #1201133

    Hello. I upgraded my CSS in order to remove the date / time stamp on the Nishita Theme & used .entry-tags, .photo-meta ul li.first, .date .archive-wrapper, h4.post-meta {display: none;} which did work + I removed the meta widget. However, the date/time stamp still appears when viewing on a mobile device. Is there an additional code needed to remove it from mobile version?

    The blog I need help with is jaquelinephillips.wordpress.com.

    #1201255

    I tagged this thread for a Staff follow-up. Please subscribe to it so you are notified when they respond.

    #1201480

    kobenland
    Member

    Hi Jaqueline,

    Unless disabled, we use a mobile theme for requests from mobile devices by default. Since this is essentially a different theme, chances are that you CSS customizations don’t work for it.

    As a solution you can select the “Apply to mobile theme” option in the custom css editor, and then specify CSS rules for it. To make sure that your additions do not have repercussions on your regular theme, make sure to prefix all selectors with the .mobile-theme body class.

    Best,
    Konstantin

    #1201484

    Thanks Konstantin. The custom CSS “apply to mobile theme” option had already been checked but wasn’t working, the date stamps were still appearing when using a mobile. For now, I’ve turned off the mobile theme which adheres to the custom CSS but does give it a slightly different look. (I wasn’t sure where to paste the .mobile-theme CSS. I tried putting it next to the original but without luck.

    #1201489

    kobenland
    Member

    You could try
    .mobile-theme .entry-date { display: none; }

    #1201518

    sixhours
    Staff

    Howdy! Just checking in. Any luck with @kobenland‘s suggestion?

    #1201525

    No, but I just removed the mobile theme option & although it doesn’t load with the same view on mobile, removing it takes the stamp away

    #1201526

    sixhours
    Staff

    Great! It sounds like you’ve got it sorted then?

    #1201531

    Not really, but good enough for now, yes.. I wanted to keep the mobile theme & also apply the same CSS rules to it. That didn’t work so I removed the mobile theme which views a little differently when using a smartphone. It’s not displaying the date stamp (but also not displaying the mobile theme either). Which for the moment is fine until I come back later to try & re-figure out if it’s actually possible. Thanks for checking in!

    #1201552

    Hi Jaqueline,

    I was able to hide the post date on the mobile theme using the same code provided by @kobenland below:

    .mobile-theme .entry-date { display: none; }

    Just make sure that when you customize your CSS that you select the “Include this CSS in the Mobile Theme” option. You might experience a delay in seeing it properly on the mobile device, so I would wait a few minutes before checking it.

    #1201553

    martinrowe
    Member

    how to get rid of “Posted on” wording?

    #1201554

    martinrowe
    Member

    and blog categories? …martinrowe.wordpress.com

    #1201557

    @martinrowe, this thread is about the Nishita theme, and http://martinrowe.wordpress.com/ is using the Twenty Ten theme. Can you please create a new help request in the CSS forum with your question? Make sure to include a link to the WordPress.com blog you’re working on and mention which theme you’re using. CSS is theme specific.

    #1201558

    Thanks guys.. I tried the code at the end of my other custom CSS, included mobile theme, waited 30 minutes, did a mobile refresh & the date stamp is still there. (i-phone 4) It’s ok, I don’t mind it that much actually. & disabling the mobile theme brings me to the black background I prefer anyhow & also removes the stamp. That works for me.

    #1201559

    Is there any way to remove my user name from this original post now? :-)

The topic ‘Remove Date Time Stamp on mobile version of Nishita’ is closed to new replies.