Remove "Leave a Comment" text and box

  • Author
    Posts
  • #1044250

    I was able to remove the comments function from my new “Adventure Journal” theme site, but for some reason the text and broken link “Leave a Comment” still appear on some pages (notably, at the bottom of my RSVP page: http://stivershamblen.com/rsvp). Is there any code I can use to remove this? Or perhaps cover it up?

    I’m also looking for CSS code to change the appearance of my RSVP form — unbold the field headings and make some of the text boxes smaller, for example.

    Help?

    The blog I need help with is stivershamblen.com.

    #1044351

    timethief
    Member

    That’s not a CSS issue.

    Comments on all pages and posts on every WordPress blog are enabled by default so that means you disabled them on the posts you refer to.

    This page > Settings > Discussion
    Discussion settings is where you set up defaults for comments.
    http://en.support.wordpress.com/settings/discussion-settings/

    We can also override the default settings and enable or disable future comments on any individual post or page.
    http://en.support.wordpress.com/enable-disable-comments/

    Note: By default, new blogs on WordPress.com will have the Discussion hidden. You can reveal it by clicking on Screen Options http://en.support.wordpress.com/screen-options/ on the top right corner of your Admin page, and checking the box that says Discussion so the module is included. http://en.support.wordpress.com/modules/#list-of-modules

    #1044352

    I’ve unchecked every box on the Discussion page and the words “Leave a comment” still appear on my RSVP page.

    http://stivershamblen.com/rsvp/

    I’ve read elsewhere (http://wordpress.org/support/topic/leave-a-comment-link-wont-disappear) that this is a glitch with WordPress that needs to be corrected through the PHP file, but I don’t know how to access and change that, so I am hoping to find a CSS solution.

    #1044395

    justpi
    Member

    1) Don’t read “elsewhere”. The wordpress.ORG forum is for self-hosted blogs: different software, different possibilities and restrictions, different problems and solutions.

    2) Timethief linked to the relevant Support doc: you probably didn’t read it carefully enough. The changes you make in Settings > Discussion become your new defaults, i.e. they apply to posts/pages you create after you’ve made those changes: they don’t apply to already published posts/pages. To disable commenting on an already published page such as the one you linked to, go to Pages > All Pages, hover over the page title, click Quick Edit, uncheck the option ” Allow Comments”, click Update.

    #1044423

    Justpi THANK YOU…! ive been looking for that solution for days, can’t believe it was that easy…

The topic ‘Remove "Leave a Comment" text and box’ is closed to new replies.