remove page title on page

  • Author
  • #477980


    Hello, I am using twenty ten theme and on all my pages the page title is also shown. How can I remove the page title from the pages?
    Look at
    The blog is in Dutch.


    The blog I need help with is



    Without URLs how will the Pages be accessed?



    It has nothing to do with the URLs:
    Look at for example at:
    The name Fair Chile appears on top of the page. I do not want to have it there.

    Thanks for the response!


    Correct, nothing to do with the URLs: changing the page title (including deleting it) doesn’t change the page URL. The problem is that deleting the page title would mean no page tab in the top navigation too.

    What I would normally do is use code to push the content of the page upwards and cover the actual page title with the heading you’ve written. Unfortunately this won’t work in Explorer (no surprise)… So the only other thing I can think of is to mask the title with a white image. But this will leave too much space between the top navigation and the heading. If you don’t mind that, I can work it out for you.



    Thanks panaghiotisadam for your response.
    However, when putting an image on a static page it will remain below the page title and the page title remains visible.
    Any idea how to solve this?



    Unfortunately I did not express myself well when I questioned you. Fortunately, Panos did when he said:

    The problem is that deleting the page title would mean no page tab in the top navigation too.

    Best wishes to you both for finding a solution. :)


    Create a 640×40 image, upload it via Media > Add New, copy the URL you’ll get, and put it at the beginning of the page (in the html editor, of course) this way:
    <img style="position:relative;top:-55px;" src="IMAGE URL HERE" />
    It can be a plain white image, or a white image with your “artificial” title on it.



    Hi panag,
    Thanks a lot! It works!
    But …. the white space between the top navigation and the text is now really big.
    You can see it at:
    I think this is because there is a ‘hard return’ after the image.
    I get a similar extra white line after every hard return in the text and I also have not figured out yet how to get rid of this white line.
    Further suggestions are very welcome!




    change the -55px to, for i.e., -20px

    That will change the space in-between.You can play around with the numbers to get the results you desire. You can also adjust the image “” size from 485px × 40px to 485px × 20px to adjust height.

    Hope this help.



    This helps a little bit, but not as much as I would like.
    I changed the -55px to -75px (to get it up on the page a bit) and now the page title (Fair Chile) is just becoming visible (so with -72px I will just have it covered). Still a lot of white space as you can see:

    More suggestions??


    @phatpast: No that doesn’t help! The numbers were carefully calculated to place the image in front of the page title (and the exact positioning varies from browser to browser).

    @galopen: Don’t change any of those numbers please. Enclose your heading in this code:

    <div style="margin-top:-70px;">

    This number you can change.



    This works!
    You’re brilliant Panag!



    Unfortunately I discovered a drawback for this last option:
    In the Top navigation I have sub-pages (Route). The ‘white box’ picture covering the page title Fair Chile also covers the ‘folding-out’ sub-pages from the top-navigation ‘Route’ which disables accessing sub-pages via the Top-navigation.
    Look at:

    I am afraid I’ll have to stick with page-titles on my pages, or is there still another solution??


    Image covering page dropdowns? Not in any of the browsers I checked it with (Safari, Firefox, Opera, Explorer, Flock). Which browser and version are you using?



    Yes, sure! I use Windows explorer version 8.
    However, I checked using Firefox and there it works fine!

    I have put a screenshot of what I get at the bottom of the page:

    No joke!
    I will check how it looks on other computers, but that will be on Monday.


    I see (I’m using IE7, that’s why I didn’t get that). IE stubbornly refuses to conform to various web standards, but many users use it so you can’t ignore it, so I’d say forget the whole image idea.

    Alternative solution: delete the page title, copy the page URL, create a new page and turn it into a link to the untitled page as explained here:



    Did I already mention that you’re brilliant?



    I found another way to do this, but I’m a newbie and not sure I can give it step by step. I just edited my landing page’s title (a static home page) to be “named” one space on the space bar. Then it did not show up on the page. In my list of pages it was designated untitled, but I was still able to select it to add it to my menu. I was also still able to designate it as the static front (home) page.

    I am not sure if this will have downsides later – if anyone knows, please warn me. I think the main thing would be for me not to have other untitled pages so things don’t run amok. URL seems unaffected. Seems much simpler than uploading a white image and all that.

    Not sure if it would work for everyone – I am a Vista Firefox user.

    You can see if it looks right to you at . Warning: blog under construction, barely started.

    If anyone wants to take a crack at step-by-stepping this so it would be more helpful, be my guests. I struggle with the WordPress lingo & don’t have time to do it today.


The topic ‘remove page title on page’ is closed to new replies.