Request help making home page posts page

  • Author
    Posts
  • #888045

    whitt88
    Member

    Dashboard-Appearances-Reading gives me two options Static and Posts. I probably started out wrong. When I use the static page (down to the sea in ships) for entry, clicking on Home brings up the posts. But when I select Posts for entry (non static page), the home page contains only the header, no posts appear. Where have I erred? Sorry.

    The blog I need help with is whitt88.wordpress.com.

    #888148

    You want to choose Front page displays __ Your latest posts which is the top selection. That will set your “main landing page as your posts page.

    Did you create a custom menu? If so, go to appearance > menu click on the right end of the “home” page title bar in the custom menu and edit the URL so that it is http://whitt88.wordpress.com/ and then save the menu.

    #888149

    whitt88
    Member

    Thanks for the leads, I’ll go to work.

    #888151

    You are welcome and you know where we are if you run into trouble.

    #888152

    whitt88
    Member

    Must be the Sacred Path which makes you so patient.

    I sill can’t get my settings right. After resetting Front Page displays to Posts, the Home page becomes empty.

    In appearance, menu, I click on the down arrow and the window opens, but where is the URL to be modified. Sorry again.

    #888157

    Are you using a custom menu?

    #888158

    Never mind. Delete the “home page” menu item from the menu. Then create a custom link. For the label put “Home” and for the URL put the URL of the main page of your site.

    #888160

    whitt88
    Member

    No luck.Tried what you suggested; deleted, make custom link. Home appears in menu, click brings up wordpress.com/blog-page/ but no blog or posts appear.

    #888161

    whitt88
    Member

    Yes, it’s probably the custom menu, which I don’t need yet. Should I delete it too.

    #888162

    justpi
    Member

    Go to Pages > All Pages, hover over the Home page you have created, click Trash.
    Then go to Appearance > Menus and
    • click the Home item to open it, click Remove;
    • click View All in the Pages module, select the ready-made Home item, click Add to Menu;
    • drag the newly added Home item to top position, click Save Menu;
    • make sure this menu is selected in the Theme Locations pulldown.

    #888163

    whitt88
    Member

    Thanks for coming back justpi. I’ll go do it.

    #888166

    whitt88
    Member

    Where has success gone. It won’t work. I’ve tried everything. SOS (save my site)

    #888170

    justpi
    Member

    So far you only trashed the (useless) static page you had created. The four bullets above are the exact steps you need to take.

    #888171

    whitt88
    Member

    Home is now absent in Menu.

    Can’t find “theme location pulldown”

    Can you do it from there?

    #888172

    whitt88
    Member

    Found it up in Menus. Two hours to fix this. It that just me???

    #888173

    whitt88
    Member

    Anyway, thank you for giving me your time.

    #888174

    justpi
    Member

    You’re welcome.

    “Found it up in Menus.”
    Well, my four bullets above were all under “go to Appearance > Menus“.

    “It that just me???”
    No, it’s most inexperienced users, because custom menus are a tricky and convoluted business, and WP hasn’t made things very intuitive: for example, beginners don’t know that several default dashboard screens don’t include everything you might need (so you need to click Screen Options to activate some things), and headings such as “Theme Locations” are incomprehensible to the average user.

The topic ‘Request help making home page posts page’ is closed to new replies.