Need help? Check out our Support site, then

Revisions disappeared from my Dashboard...

  1. ... I was having problems with saved versions not "sticking", but by going to the "Revisions" screen I was able to restore my revised versions.

    Now all of a sudden I cannot find any link to that screen - did they change things around? Anybody knows? (I just lost a great deal of text in a draft, and would love to be able to retrieve it)

    thank you!

    The blog I need help with is

  2. I found it! They did move it around, it is on the dasboard still, but right above the "PUBLISH" area, a tab called "Revisions" with a "browse" option, and the number of revisions made.

    I am changing this to solved....

  3. I seem to have yet another problem...

    the draft post I kept trying to restore has 17 revisions according to the Dashboard. However, if I try to restore the last revision by clicking on the "RESTORE THIS REVISION" absolutely nothing happens. It behaves as if that button is not active.

    is this happening to anyone else? Basically I seem to be stuck with an earlier version of the draft and be unable to use the stored revisions already made...

  4. Anybody home???? :-) Still the same problem.

    It seems that the "Restore this Revision" is a dead, inactive link as far as I can tell from my Dashboard....

    I will try to go in another computer, maybe this is related to my MacBook...

  5. rightupmytweet

    Hi Sally - I'm having the same problem. When I restore the back up or a revision and click Publish it show the restored version but then in the dashboard still shows as a draft, not as the restored version and the shortlink goes to the original draft.
    I'm also using a macbook.

  6. Thanks, Peter

    I just checked and the situation is exactly the same in an IBM computer.

    I ended up having to go into my revision, doing a copy and paste of all the new text, adding to the outdated draft, and then I immediately scheduled for publication, pending review. I don't want to lose my work anymore...

    I am sure now, from your input, that this is a problem that needs to be addressed by the "higher powers". Let's hope they see this ;-)

    thanks for the feedback!

  7. I've tagged this for Staff assistance.

  8. Thank you!

  9. rightupmytweet

    Thanks Jennifer, Thanks Sally. I've resolved it by using Sally's solution but it was driving me nuts!

  10. I'm glad it's resolved now. Please let us know if you need any further assistance!

  11. it is not resolved! what we did was to find a very convoluted way around the issue.... The clickable button Restore this Revision is dead and needs to be brought back to life....

  12. Sorry for the confusion. Do you also encounter this issue in a different browser? for example Internet Explorer or Google Chrome?

  13. Will check it out in a little while and get back to you....

  14. Ok, I am back... progress made: it WORKS in Chrome, but it doesn't in Firefox....

    now, the big question: does that mean we should all go to Chrome, or is it something that could be "fixed" for Firefox browsers????

  15. Are you running any browser extensions/add-ons in Firefox? if so, please tryo to disable them:

    Otherwise reset Firefox using these steps:


    Oh, that is wonderful... thank you thank you thank you!

    I reset Firefox, as removing the add-ons did not seem to help.

    I hope others who are struggling with this will see this thread... it's been very frustrating for quite some time

    Marking as SOLVED. With a big smile ;-)

  17. You're welcome! Feel free to contact us if you have any other questions.

Topic Closed

This topic has been closed to new replies.

About this Topic