Rounded Theme blog post formatting issue

  • Author
    Posts
  • #805285

    amymjacobson
    Member

    Help! I am using the Rounded Theme but all of my blog posts have a funky formatting issue. Nothing I do fixes them. There must be something in the CSS but I just don’t know where I would change this and what I need to change.

    The blog I need help with is healthygrits.com.

    #805485

    Is this blog, http://amymjacobson.wordpress.com/ , the one you are talking about that hasn’t had any activity since 2009?

    If not, then we need a link to the site you are talking about, and could you explain a little further what you mean by “funky formatting?”

    #805487

    amymjacobson
    Member

    no sorry it is healthygrits.com
    I mean when i type it out to post it looks normal but then when I do post, there won’t be spaces between paragraphs or the paragraphs will be indented and shouldn’t be. If i go back and try to manually add spaces, sometimes it will make it look better and other times the additional spaces don’t make any difference.

    #805488

    Are you copying and pasting from the web or from a program such as MS Word?

    #805508

    @rich: I’m not seeing any Word junk in the sourcecode – just lots of empty divs (probably attempts to create space by hitting enter).

    @amy: Make sure the Format tool (Row 2 tool 1) is set to Paragraph then type or edit the content.

    #805509

    I’ve been noticing lately on a couple client’s blogs where pasting from Word seems to turn everything to divs much of the time causing me to run around behind my clients cleaning up.

    I was going to wait to hear back and then do the “highlight everything and select paragraph from the pulldown” thing. Although that has not been working consistently on the self-hosted client sites. Sometimes it works and sometimes it does not. TinyMCE is such a kludge. I seriously wish there was a good alternative out there, but they have a stranglehold on things.

    #805529

    amymjacobson
    Member

    i almost always free type it in so the word paste thing shouldn’t be causing any problem. I have also tried the paragraph thing before and still no solution.

    so basically the answer is that even thought this format works great for everything I need structure and aesthetically speaking, the formatting is inherently bad from the theme creator?

    really stinks if there is no way around it.
    I was hoping I could add/remove something from the CSS that could fix it.

    #805531

    “the formatting is inherently bad from the theme creator?”
    We didn’t say that, and it’s not a CSS issue. No spaces between paragraphs happens when Paragraph isn’t selected in the Format tool. When you type in the Visual editor, and Paragraph is selected, you get a paragraph break when you press return and a line break when you press shift-return.
    Or you can type in the HTML editor where you can see that no unwanted HTML tags crop in: in the HTML editor, pressing return gives you a line break and pressing it twice gives you a paragraph break.
    Or you can type the text in a word processor and copypaste it into the HTML editor.

    For your already published posts, you can select all in the visual editor and click Format > Paragraph. This will turn everything into paragraphs, and you can then delete the extra blank lines where you don’t want any.
    Or you can switch the editor to HTML and delete all these:
    <div>
    and all of these:
    </div>
    But first go to Settings>Writing and tick the option “WordPress should correct invalidly nested XHTML automatically”, just in case.

    #805533

    amymjacobson
    Member

    thanks for the suggestions. i’ll try using them this evening to see if it helps.

    #805536

    You’re welcome. Additional suggestion: never press return repeatedly for extra space. The web standard is one blank line for a paragraph break: trying to add more space via multiple returns may mess things up.

The topic ‘Rounded Theme blog post formatting issue’ is closed to new replies.