RSS feed cropping

  • Author
    Posts
  • #162433

    dpotter
    Member

    A colleague has set up the RSS feeds for my blog, advancingthestory.wordpress.com. When imported into another site, http://college.cqpress.com/advancingthestory/, they are cropped off based on number of characters, I think, which looks awkward. Is there a way to set up the feed so it takes the first full paragraph? Or can I use some kind of excerpting to make sure the RSS feed gets a complete sentence or two? I have searched the FAQs and forums to no avail. Thanks!

    #162752

    trent
    Member

    If you go to your blog Admin => Options => Reading, just turn on the “full text” versus the “summary” in the Syndication Feeds section.

    Trent

    #162757

    Do realize that if you display full text in your RSS feed, it makes it easier for blog scrapers to steal your content.

    #162758

    trent
    Member

    I don’t think they care because they are using blog scraper software as the main problem issue to import the content from their site! ;)

    Trent

    #162761

    Oops, I should have read more carefully.

    #162844

    dpotter
    Member

    Thanks for the suggestion. Unfortunately, the “full text” option was already selected, so that’s not the solution. It appears that the RSS feed is sending only the first 100 characters. Ideally, it would send complete sentences, but I’d settle for ending on a complete word! Current example: Lots of news organizations have created crime maps online; many of those maps include searchable dat…
    Is it possible that this clipping is dictated by the code on the importing page, not WordPress at all?

    #162845

    justjennifer
    Moderator

    I think you are right. It looks like that intro page on http://college.cqpress.com/advancingthestory/ is just showing a “thumbnail” of the entire post.

The topic ‘RSS feed cropping’ is closed to new replies.