RSS Feed not detected with Monochrome theme

  • Author
    Posts
  • #442459

    fernmann
    Member

    Hello,
    some days ago I switched to the Monochrome theme and noticed that the RSS-Feed isn’t shown in the URL-Bar of the browser (tested with Chrome and Firefox). If I switch back to another theme, the feed is detected correctly again. I’m not alone with this, every other WordPress.com-Blog I visited who was running the Monochrome theme had this problem.

    In comparison with the source code of the demo (http://www.mono-lab.net/demo1/) – where the feed detection is working – I noticed that following two lines are missing in my source code:


    <link rel="alternate" type="application/rss+xml" title="DEMO SITE1 RSS Feed" href="http://www.mono-lab.net/demo1/feed" />
    <link rel="alternate" type="application/atom+xml" title="DEMO SITE1 Atom Feed" href="http://www.mono-lab.net/demo1/feed/atom" />

    Could this has something to do with that problem?

    (I’m not a native speaker, sorry if my English is bad)

    The blog I need help with is fernmannblog.wordpress.com.

    #442620

    timethief
    Member

    That’s interesting. I had the same problem several days ago and posted a thread to give everyone a heads up about the RSS feed not working here https://en.forums.wordpress.com/topic/monochrome-theme?replies=1#post-425152

    I used http://ismyblogworking.com/ and found my RSS feed was not detected. I went to the feed validator and got bad news there too. To make a long story short I switched themes twice and when I did that the feed was detected both times and did validate.

    I hope you have found the solution.

    #442641

    filsalustri
    Member

    I’ve been having the same trouble with Monochrome. I tried switching to some other theme and back, several times. I tried add the RSS Links widget. I tried disabling the RSS sidebar theme option and then turning it back on.

    No matter how often I did it, the feed doesn’t turn on – firefox doesn’t see it and ismyblogworking doesn’t see it.

    Dunno what else to do, and it would be a shame if I had to switch themes again just cuz of that one bug.

    #442646

    timethief
    Member

    There’s only one option here for getting this fixed and that’s taking this issue to Staff. I’m not using the theme any more so I did not do that. Here’s the link http://en.support.wordpress.com/contact/

    #442673

    raincoaster
    Member

    I don’t believe Monotone or Duotone have feeds. Duotone MIGHT, though. Monotone isn’t widgetized, so they may have thought there’s no point.

    #442676

    timethief
    Member

    A lot of bloggers, who do not have photoblogs, are currently using that theme and appear to be either unaffected, or blissfully unaware of the fact that the RSS feed ain’t happening. This is despite that fact that the option to have the RSS feed appear is presented on the Monochrome options page.

    #442729

    thebrotha
    Member

    I’ve been using Monochrome for a week now and I’ve had no problems with my feeds. It’s odd that a lot of bloggers should have issues while some don’t.

    Take heart, a fix could hopefully be on the way.

    #442731

    raincoaster
    Member

    Note that if you’re scheduling your posts to auto-post at some other time than the composing time, there is an RSS bug that prevents them from going out at that time.

    #442733

    timethief
    Member

    That’s a good heads up but it wasn’t a factor in play in my case.

    #442735

    timethief
    Member

    @thebritha
    Read this and you will be singing a different tune http://ismyblogworking.com/thebrotha.wordpress.com

    I had the same error report: Your blog doesn’t advertise an XML feed. Are you sure it’s a blog?
    RSS feed supported – no

    Feed validator report – It looks like this is a web page, not a feed. I looked for a feed associated with this page, but couldn’t find one. Please enter the address of your feed to validate.
    http://feedvalidator.org/check.cgi?url=http%3A%2F%2Fthebrotha.wordpress.com%2F

    #442823

    fernmann
    Member

    OK guys,
    sent an support request to the staff.
    Let’s stay tuned.

    #442829

    naokomc
    Staff

    Hi,
    Thanks for noticing this.
    The theme has been updated now.

    Thanks again!

    #442830

    timethief
    Member

    YAY!

    #442866

    fernmann
    Member

    No problem,
    I have to thank you for the fix, it’s terrific! :-)

    #442882

    filsalustri
    Member

    BAM! I love the speedy response. Thanks so much for the fix!

The topic ‘RSS Feed not detected with Monochrome theme’ is closed to new replies.