“save” button not saving my work

  • Author
    Posts
  • #188382

    I’ve been on WordPress for months but for the past two days, when I hit “save and continue editing” or just “Save”, it doesn’t save anything. Please advise. Thanks!

    #188489

    raincoaster
    Member

    Can you please either link your username to your WP.com blog (under Profile–>website) or give us a link to the blog in question?

    #188545

    Thanks for responding raincoaster

    My Domain: mayavision2012.wordpress.com
    User name: mayavision2012

    #188546

    raincoaster
    Member

    I see this post:
    http://mayavision2012.wordpress.com/2008/02/04/blood-and-treasure-the-newest-mcromney-catch-phrase-that-reminds-me/
    And before it nothing till the First; are there other posts you tried to make in between?

    When you hit Publish, it publishes? But when you hit either of the Save options, it just goes poof? Is it visible under Manage–>Drafts? If so, what is the timestamp on the missing posts? It could accidentally have been set to the future.

    #188559

    Re posts:
    The latest two were 02/01 and 02/04 so no missing posts in between. It did publish my latest post “blood and treasure…” but I am unable to save any edits I might make to this AND to earlier posts I have published.
    Thanks for your help. I hope I can get it resolved.

    #188561

    raincoaster
    Member

    Are you totally sure you aren’t having a browser cache issue? Clear your browser cache and cookies and do a forced reload of your blog page. See if the changes you tried to make are there now. It could be you were just looking at an old version of the blog.

    #188565

    I have already cleared all temp files/browser cache/cookies twice. I do see now that quite a few posts are showing up that people on other blogs are not able to save their work either, starting about 01/28/2008, it appears. So I am wondering if this is a more generalized WP problem?

    #188807

    xynar
    Member

    I’m having the same problem, I was working on something, and it autosaved, but then wouldn’t save when I tried to do it manually, so it’s not keeping the end of what I wrote.

The topic ‘“save” button not saving my work’ is closed to new replies.