Save draft – everything disappears

  • Author
  • #1219460


    I had been working on a post, and had been regularly saving by clicking on the “save” button while in distraction-free mode. I left distraction-free mode, and then clicked “save draft”, and my entire post, except for the title, disappeared. The draft remained, but all of the content was gone. I went back to look at my revisions. The most recent couple of revisions – 3 or 4 – were all blank as well. But before that the content had saved properly. I resumed working on the post from that earlier successful saved draft, but then it happened again several hours later, exactly the same.

    I made a draft without any problems a little over a month ago.

    I am using Firefox as my browser. After it happened for the first time, I disabled all of my add-ons and extensions, though I didn’t have any related to WordPress. I deleted my cookies and cache. This didn’t make any difference, since it happened again.

    I’m not sure what to do or what’s wrong.

    The only time I’ve ever had a problem before was when I made a huge post several years ago with a ton of large GIFs and HQ images. The post I’m working on right now contains quite a few images but not nearly as many as that other post, and I’m still in the middle of it, not towards the end.

    Please help!

    I’m not very savvy, I don’t have any WordPress plug-ins and I haven’t messed around with anything except simple things like changing my header and arranging my widgets.


    I’ve had that happen to me before a few times (didn’t learn from the first time). It seems to happen after I hibernate my computer, and then reawaken it. If I’ve had the post editor open, and then continue to work in it, and then press save, it comes up with “do you really want to do that?” or something similar. Then if you go back, everything is still gone. (A similar thing happens with Youtube videos after hibernation, you have to reload the page to continue watching).

    I’m sure there’s some technical reason behind it all, but I just know that to avoid this, just refresh the page, or better yet, close all wordpress tabs before hibernating, that way it won’t be an issue. Of course, w you could use an offline-editor to write you posts, so you’ll always have a copy on your own computer. See here for more information:

    If this isn’t relevant to what happened to you, sorry. But I know from experience that when that page comes up, I don’t think there’s a way to find it again. The revision wasn’t saved, so it doesn’t really exist. Sorry.



    I was continually working on the draft the entire time – I never put my computer into standby or hibernation.

    I did realize that before it happened both times I pasted a GIF into the draft instead of going through the uploader. I had never done that before, just tried it on a whim and saw that it worked. it’s possible that that is the point at which the drafts no longer saved and everything was wiped away. Is pasting an image instead of uploading an image known to cause problems?

    I’m not certain that pasting the GIF was the cause, I just realized as I was thinking about it lasts night that it was possibly related.



    There is a long standing issue Staff are addressing in the next upgrade.

    The new auto-save system arriving very soon will keep that from ever happening. Keep your eyes on for the announcement.

    You may be able to recover a post revision. Go to Posts > All Posts, hover over the title of the post, click Edit and check the Post Revisions module for previous saved versions of the post.

    If you’re not seeing the Revisions module while on the editor screen, click Screen Options (top right corner of your Admin page) to activate it. Then select the post and page modules to include them. Then you ought to be able to go here > Dashboard > All Posts > Posts and locate the post and recover it from post revisions.

    If you cannot locate the post for locating and restoring a post revision, and it’s not in your Trash folder then you will not be able to recover it.

    Did you create your post on the dashboard of your own blog?
    Dashboard > Posts > All Posts > Add New

    Or did you create your post on the front page of!/post/

    Create your posts on the dashboard of your own blog
    Dashboard > Posts > All Posts > Add New

    Or use an offline blog editor so you always have backups on your own computer



    I did not create the post through: Dashboard > Posts > All Posts > Add New, but I will do that from now on.



    I am absolutely livid. The same thing just happened to me.



    I have been there too and I’m so sorry this happened to you.

The topic ‘Save draft – everything disappears’ is closed to new replies.