Save draft option apparently missing?

  • Author
  • #521750


    I am trying to edit a draft post,and the only option showing is “PUBLISH”

    the “SAVE DRAFT” is nowehere to be found.

    Am I the only one with gremlins at work? Or is it a widespread problem?


    The blog I need help with is



    Bringing this to the top, as I’m still having the problem, I logged out and back in, no changes. The save draft option is simply gone…..



    Just adding some additional info on the problem – I cannot preview either. So the only thing I can do with a draft is to publish it without even previewing. Very frustrating.

    If I edit and try to go out of the screen, I still get the pop up asking me if I really want to leave without saving the changes made – but since the option to save is not there, I am forced to cut and paste my text into a Word document to save my editing….

    From the lack of replies, I suspect it’s just me having trouble????


    I still have a draft and a preview option…



    Hi Sally,
    I saw your thread but am not experiencing the problem.
    Have you gone through the entire troubleshooting drill?

    1. Some issues that you encounter with your WordPress blog or account can be solved by changing your browser settings, refreshing the page, or clearing the browser cache and cookies. See here > The instructions for specific browsers are found here >

    2. Some issues can be resolved by upgrading your browser.

    3. Some issues can be resolved by using another browser.

    4. Some issues can be caused by not updating your Flash. You can use this link to see if your flash is up to date. If it’s not then go to and download and install the latest version of flash.

    5. Some issues can arise from the way you connect to the internet (mobile, satellite, DSL, dial-up) and to your blog and how many proxy server jumps etc. it takes to connect. There maybe be problems with your ISP and/or with the proxy servers. There may be problems with your web host. Check known issues with your ISP and with your web host.

    6. Sometimes operating system and/or security system updates can cause issues. Check for known issues.

    If none of the above work for you then please file a support ticket with Staff using this link

    Staff need to know:
    What is your operating system?
    Which browser and version of it are your using?
    Has your security program and/or firewalls been recently updated?



    Gosh, this seems serious… I had already cleaned my cache, after reading your reply I checked my version of Flash player and downloaded the newest one. Change the connection to another host (we have two options available here), tried to use Internet Explorer instead of Firefox

    No help, I still cannot see the save draft or preview….

    I will file a support ticket, but I’m afraid it might take a long time to hear from them…

    thanks for your input, I wish it had fixed the problem, but apparently there’s something really fishy going on



    Sorry this is happening. This is a long shot but have you tried to post by email?


    @sally, open up a post in the editor and then click on the “screen options” button at the top right. Switch to 1 column and then back to 2 column. Then look below the post text area and see if the “publish” module is down there. If so, you can drag it up and to the right of the text area (wait for the grayish box to darken and then release. You can do the same thing with the categories module and tags module.


    Moderator Emeritus

    If you have a private test blog, you might be able to write and edit your post until staff gets back to you. It’s a long-shot but it might work. ≥^!^≤



    @thesacredpath: now I’m in serious trouble. I did that, and now all options are gone, I cannot even publish!

    Changing to one column and back removed every single option that is available, there’s a blank space where the PUBLISH thing used to be, and that option is not anywhere on the screen.

    It is possible that I am going to cry at a corner in a few minutes….. (half joking…)



    @tess: my practice blog is suffering from the same problem. No publication is possible, all buttons are gone, gone, gone….

    @timethief – I’ve never published by email, but I am not sure it would work under the present circumstances –

    anyone got a virtual Kleenex?




    I got a reply from staff, and just sent them a screenshot of my editing screen

    Trying not to go into hyperventilation mode here….

    THanks for your input, I’ll keep you posted



    Sending you a huge HUG – don’t forget to breathe, breathe, breathe.




    It is restored! The poor guy has been emailing back and forth with me for a long time, but finally he told me to read this page very carefully and see if I could find the “publish” button hiding somewhere

    the thing was at the very bottom of the screen, so I clicked and dragged it to its default location – I thought only the “publish” feature would be restored, but once I put the button back there, it “opened” into its original multiple purpose – that is, save draft, and preview available….

    I think I lost a couple of pounds sweating today…. can you guys tell I’m a little thinner?

    I am marking it as solved and including the link so that if other unlucky campers suffer the same ordeal, maybe they can quickly solve it….

    Thanks for all your help, you guys are great!

The topic ‘Save draft option apparently missing?’ is closed to new replies.