Set up Youtube Channel as page link?

  • Author
    Posts
  • #1104109

    h3llion
    Member

    Hello, I am curious if it is possible to set up youtube as a link on wordpress, outside of the blogroll. My blog is @ http://youthstrikesback.com. I am currently not running a customized page, but I plan to in the near future. For the purpose of providing an example, if you check out the blog @ http://39degree.blogspot.com/ you will see what I mean. Below the header is a “Our Youtube Channel” link which, when clicked, opens the youtube channel. Is it possible to do this in wordpress?

    Thanks, and happy blogging.

    The blog I need help with is youthstrikesback.com.

    #1104251

    timethief
    Member

    Have you tried setting up a custom menu and then including a custom link to your YouTube channel in it?
    http://en.support.wordpress.com/menus/
    http://en.support.wordpress.com/menus/#adding-custom-links

    I’m asking because I don’t have time to do that for you in my test blog and then provide an answer here.

    #1104259

    h3llion
    Member

    I have not tried that, but it appears to be exactly the solution I was looking for. Thank you for the suggestion…I will try it when I get back to my computer. Happy holidays!

    – H3

    #1104263

    timethief
    Member

    Happy Holidays to you as well. :)
    Please do post to let us know if this worked for you or not.

    P.S. There are many common errors, misunderstanding and misconceptions when creating custom menus and you can read about them here > http://wpbtips.wordpress.com/2011/12/19/custom-menus/

    #1104455

    h3llion
    Member

    Posting back…worked like a charm. I’ll read the link on the issues…I appreciate that.

    I DID have to add a “home” button that just redirected back to the main page, so don’t forget to add that or else your readers won’t have a direct link back to the blogroll.

    Thanks for the help! Merry Christmas.

    #1104579

    h3llion
    Member

    I do have a follow up question on this…the way I have the links set up in menu, it opens whatever the target is in the existing page. Is there a way to code it so that clicking the link will open in either a new window or new tab? Thanks,

    – H3

    #1104580

    timethief
    Member

    Forget using shortlinks. To open links in a new window the format must be as follows. Instead of this:
    <a href="URL HERE">TEXT HERE</a>
    you write this:
    <a href="URL HERE" target="_blank">TEXT HERE</a>

    #1104581

    h3llion
    Member

    I can’t seem to get that to work the way that I previously was using the menu tab in dashboard. No worries…I’m getting ready to switch themes and go full custom, so I don’t want to waste to many resources on it at the moment. Thank you for the help!

    Since we’re talking about links, I made a post earlier using the target code for a new window for some of the places that I mentioned, and the links would only show up in IE. When viewed in firefox (I have the most current version,) the links were missing and nothing was in their place. How can I correct this?

    Thanks again, timethief. Hope santa was good to you this year…you’re awesome.

    #1104585

    jenia
    Member

    Hi H3,

    the way I have the links set up in menu, it opens whatever the target is in the existing page. Is there a way to code it so that clicking the link will open in either a new window or new tab?

    Yes, you can check the “Open link in a new window/tab” option for any of your custom menu items. To reveal this option, expand “Screen Options” (top right corner) under Appearance > Menus, then check “Link Target” and the option will appear next to your menu items.

    For more info, see the screenshot at the end of the section: http://en.support.wordpress.com/menus/#additional-info

    #1104586

    jenia
    Member

    I made a post earlier using the target code for a new window for some of the places that I mentioned, and the links would only show up in IE. When viewed in firefox (I have the most current version,) the links were missing and nothing was in their place. How can I correct this?

    Could you please clarify which post you are referring to – is it this one? http://youthstrikesback.com/2012/12/28/a-quick-guide-to-christiansted/

    I viewed it and links are showing up for me in Firefox. Are you all set on this? I see that I’ve edited the post several times since originally posting this question, and that you’ve added/removed links in the process of editing. If you could let me know what steps you took and what issues you are still running into, I’ll be sure to help you troubleshoot.

    #1104587

    h3llion
    Member

    jenia – as to your first post regarding where to find the link targets, that worked out great! Thanks for the information.

    Regarding your second post, I am indeed referring to the Christiansted post. The current wordpress injected links are working. If you look back to the very first time I posted, I had tried to link the websites for each of the restaurants in the posts. When I published the post, the links wouldn’t work in firefox. In IE, they worked fine. I tried clearing cache to no avail. I dropped the links and republished, adding instead the wordpress suggested wiki-links, etc… I was using the “link” button on the wordpress new post page. Any ideas?

    Thanks for the help.
    – H3

    #1104614

    jenia
    Member

    Hi H3, I tried adding links to a post in Firefox and it worked fine for me, so I was not able to reproduce your issue. If it still persists, would you mind trying to reproduce on your end? E.g. create a private post, add some links using the Link button, then save it so that I can review it.

    #1104615

    h3llion
    Member

    I appreciate you sticking with this.

    http://youthstrikesback.com/2013/01/07/test-post/

    #1104616

    jenia
    Member

    OK, so did you try inserting a link into that test post? If you did, what browser did you use, and what happened – did it simply not take? I made a 15 second screencastusing QuickTime showing how I inserted a link in that post using Safari (I then saved the post). Are you able to do the same?

    #1104617

    h3llion
    Member

    According to my dashboard, there IS a link in that test post. It’s just not showing up for some reason. The actual post reads as follows:

    will take you to a funny gag gift.

    That is the code that the “link” creator in text view spit out for me.

    #1104618

    h3llion
    Member

    Obviously that didn’t work. Any way, I figured it out. I was trying to use the “link” button via the text writer on the wordpress dashboard. I would enter the appropriate info, and then select to have it open in a new tab, at it would keep failing. The link would just be missing. So I looked up the html code, and that was the problem. Below is a link to show the two different codes. The top one is the code I wrote, that works. The bottom one is the code that the “link” button above the new post window spit out for me, which doesn’t work.

    http://i45.tinypic.com/14mght4.png

    Hope that helps. Also, when I say the link button, I’m referring to the button inbetween italics and b-quote.

    #1104620

    jenia
    Member

    Taking your example, you’d need to type “Click this link here”, then select that text, then click on the link button and enter the URL (like I did in my screencast). It seems that you are clicking the link button without selecting any text, so that’s why you see the HTML code but links don’t show up in your published posts.

    #1104621

    h3llion
    Member

    Yep, it does work when you do it that way.

    The other way, it prompts you for the link first and then the text, but puts them in the wrong order. Thanks for the help!

The topic ‘Set up Youtube Channel as page link?’ is closed to new replies.