Setting up email problems

  • Author
    Posts
  • #1261094

    nickknackery
    Member

    I am losing the will to live!! And need some assistance. I have mapped my domain onto a WordPress blog. I am trying to have people send emails to (email redacted) and I can pick them up at another Outlook account. Obviously you all know that WordPress doesn’t do email. However, my ISP has given me 4 variations of MX server addresses and advised me to set these up in my word press account. I thought I did this all correctly but my DNS is still configurated and not complete. I’d appreciate any assistance or tips when possible, as I am not a natural here, thanks.

    The blog I need help with is graceandflava.com.

    #1261279

    auxclass
    Member

    If you post the info / 4 variations of what you have been sent by your mail host – someone should be able to review them and give you some help

    #1261290

    mansis1106
    Member

    complicated

    #1261342

    nickknackery
    Member

    Hi there, I’ve been given the information
    mx0.(ISPname).net
    mx1.(ISPname).net
    mx2.(ISPname).net
    Mx3.(ISPname).net
    Many thanks indeed.

    #1261345

    auxclass
    Member

    You left a pile of stuff out – if you are worried about security – the MX records are all public record or you email would not work – it makes no sense to me to have four MX records that are the same – so guessing at what you left out leaves the below as my best idea – remember the full stop at the end – I think what you posted is only part of what is needed

    mx1 mail.ISPname.net.

    I will flag this for a staff opinion

    #1261346

    nickknackery
    Member

    Thanks for looking at this Auxclass. Appreciate your thoughts.

    #1261360

    kevkoeh
    Staff

    Here are instructions for using email with your custom domain:
    http://en.support.wordpress.com/domains/add-email/

    You can enter DNS records in your dashboard under Store -> Domains, then click “Edit DNS.”

    It’s fine to have multiple domains here, in fact it’s good, but they all need a prefix in front to indicate what they’re for.

    In you example, it should look something like:

    MX 0 mx0.(ISPname).net
    MX 10 mx1.(ISPname).net
    MX 20 mx2.(ISPname).net
    MX 30 Mx3.(ISPname).net

    Your ISP should tell you what to put in front of the domains. Also, I’m assuming you replace (ISPname) so it’s an actual address.

    Hope that helps! Let us know if you have more questions.

    #1261370

    nickknackery
    Member

    Thanks kevkoeh for letting me know about this. I will direct my ISP to this post and hopefully sort this out. Much appreciated.

    #1261398

    nickknackery
    Member

    Hi Kevkoeh and forum members, really appreciate all your assistance. After going back to my ISP with a link to this conversation, they issued new MX records and they work! What a relief.
    Now customers can email me directly at my bespoke website and i can pick this up at another account. I have to work out what coding I need to put in so that my response appears to come back from my bespoke website. So if there are any tips on this, please let me know. Otherwise thanks again.

    #1261407

    kevkoeh
    Staff

    So are your emails being forwarded to another address outside the domain you’re using for your WordPress site? And you’re sending from that same outside address?

    If so, there’s no good way to make it look like the email is coming from your bespoke web site’s domain when it’s not (without setting off spam alarm bells). You could set a reply-to address to your WordPress.com domain, which many email programs allow you to do. That’s not perfect, but the best idea I can think of.

The topic ‘Setting up email problems’ is closed to new replies.