Need help? Check out our Support site, then

Share Daddy not working

  1. A few weeks ago, the Share Daddy sharing buttons disappeared from my blog posts and I don't know why. I do have Share Daddy enabled and Jetpack's status is showing "Connected to". Can you help, please?

    Also, do you plan to add official support for the Google+ button any time soon? I would like to avoid modifying your code to get it there and the custom service approach does not work. I have already seen it in a screenshot on your support page and you already seem to be using it so I hope you're going to release an update soon...
    Blog url:

  2. Did you enable any other plugins that could be conflicting with Jetpack? If so, please try disabling them one at a time to see if there are any conflicts.

    Google+ support in Jetpack is a great idea, but I don't have a specific timeline as to if/when it will be implemented.

  3. The only plug-in I have newly enabled is J-Shortcodes. So my first attempt to fix it was to deactivate the plug-in but it did not work. I also have a feeling that Share Daddy stopped working before I activated this plug-in.

    Another finding is that it actually works on some pages and does not on some others.

    I have discovered that the sharing buttons do appear on these posts:

    But nowhere else...

    I was trying to find any difference between the articles but with no success. Of course, the "Show sharing buttons on this post." checkbox is on for all posts

  4. ShareDaddy is actually included with Jetpack, and the two may be conflicting.

    If you have that installed separately, you can safely remove it and let Jetpack take over.

  5. I have only installed Jetpack and using Share Daddy from the Jetpack. I do not have a separate installation of Share Daddy.

  6. To rule-out a plugin conflict, do you have any luck if you deactivate everything but Jetpack?

  7. No luck. Tried to deactivate all except "Networks for WordPress" which I cannot afford to deactivate.

  8. Any chance that you could temporarily deactivate it just for a few seconds?

    If not, let's move on to ruling out a theme-specific issue. Would you please temporarily activate Twenty Eleven to see if that makes any difference?

  9. I cannot deactivate Networks. It would break the whole site and all blogs on it. It worked for months, so I doubt that it has anything to do with this issue.
    I do not have Twenty Eleven active. I use Thesis 1.8 on all my blogs. It's the only theme I have installed.
    I have tried to disable all PHP customizations in Thesis temporarily, still with no effect on this issue.

  10. Would be able to temporarily switch to Twenty Eleven, just to check?

    This is starting to feel like it could be related to Thesis, but we can't find out if you don't check in another theme first.

  11. Tried, after activating Twenty Eleven my blog does not work at all. I don't have time to experiment with my live blog and since Jetpack needs the weird connection to my account I am not sure if/how I can test this on a separate testing blog.
    I am starting to feel that disabling Share Daddy and adding share buttons on my own will take me less time.

  12. This is the part of Jetpack that seems to cause the issue:

    // Only show once
    if ( isset( $shared_with_posts[$post->ID] ) )
    $show = false;

    When I comment this out, the share buttons start showing up.

    What is the purpose of this code? How is it supposed to work?

  13. That's just a part of the code. That snippet of the code checks to see if the sharing option is turned on or off for a given post.

    I opened and checked the first 10 posts listed on that page, and I can see sharing buttons on all of the posts I checked. Perhaps you were viewing either a server-cached or a browser-cached version of the posts before? Can you clear your browser cache and check the posts again? Could you post a URL here if you find any posts without the buttons? I can check the URL and tell you if I can see them or not.

    You should also note that it's possible to turn off sharing icons on a per post basis. It's one of the meta boxes or panels on the post edit screen. So make sure to make sure the "Show sharing buttons on this post." checkbox is checked if you find a post where you can't see the buttons at first.

  14. Ah, maybe you had commented out some of the Jetpack code and that's why I can see the buttons working. If that's the case, could you set the Jetpack core code back to the way it was and check to make sure the sharing option is on for any posts where you cannot see the buttons?

  15. Yes, I have commented out the code I mentioned above.

    I already did try what you suggest. As soon as I put the code back the sharing buttons disappear from all posts except the three I have mentioned.

    This piece of code seems to be supposed to prevent the sharing buttons from appearing multiple times when the code is executed more than once for the same page/post. So commenting it out is definitely not the right permanent solution. It seems like if the page generating code was executed twice within the same PHP script for some reason and tha result of the second run was actually sent to the browser, but I hav eno idea why.

  16. Do you have anything in the page content itself that would be executing code?

  17. Only simpel shortcodes that are on the three posts where it works as well.

  18. I suggest you comment out those lines of code you found. Those lines have been changed for the next version of Jetpack because they conflict with many themes and other plugins.

    I'm not sure what changed on your site to expose this bug. Perhaps you upgraded your theme. At any rate, commenting out those lines is as good a temporary fix as any. The next version of Jetpack should work for you unmodified.

  19. OK, thanks and I am looking forward to the new version. I hope it will also include the Google+ button, by the way ;-)

Topic Closed

This topic has been closed to new replies.

About this Topic