Shares

  • Author
    Posts
  • #1300223

    I’ve enabled sharing on my blog, and the stats page shows that a number of my posts have been shared on Facebook, Press This, and StumbleUpon. However, none of the posts themselves display this information. I’ve changed the share buttons to the Official ones and this hasn’t changed. Is there something I’m doing wrong?
    I would also like to know if it is possible to be notified if/when a post is shared. I know WordPress notifies you if a post has been liked by another blogger, but I would really like to know when it is shared on external services.

    Many thanks

    The blog I need help with is letterstomydistantfather.wordpress.com.

    #1300333

    I also find it impossible to Like posts on WordPress. I’ve tried in two browsers now and the Like button is stuck on “Loading…” in both. Is there any way to fix this?

    #1300335

    meylodie
    Member

    Hi,

    The “Like” button when I test it opens a new tab in my browser on the login page. It seems I should be logged in to my account to be able to “Like” your page. I have tried this from a web browser where I am not logged in.

    About the other share buttons I don’t know. Someone else might have more information than I do.

    #1300337

    I’m glad it works for you. I can’t even click it. It’s a static part of the page, like text in the actual blog post instead of a button that can be clicked. This is the same regardless of whether I am logged in or not.

    #1300339

    meylodie
    Member

    Hi,
    It is very possible that we don’t use the same tools. I use Firefox, Midori and other web browsers in a GNU/Linux operating system. I will just suggest you try from within another web browser. You can try one or several : Firefox, Midori (exists also for Windows), Opera, Chromium or Chrome… All web browsers don’t “see” the websites the same way and all don’t make the buttons available the same way either.

    Good luck!

    #1300345

    I’ve tried in Chrome and Internet Explorer and Opera; the effect is the same. I use Windows 7. I borrowed a friend’s computer (also Windows 7)just to see if my system had a problem, but the same thing happened. The button acts like text. This is not an issue on the mobile site; I find I can like posts when signed in on my phone.

    #1300406

    meylodie
    Member

    Hello,

    Would you consider giving a try with Firefox and with Midori ? Here is where you can get them:
    http://www.mozilla.org/en-US/firefox/all

    http://www.twotoasts.de/index.php/midori
    seek in the page for “Windows”. Midori is light and fast. I have tried it in Windows too (an old XP) and it was working quite well.

    Perhaps you will have more luck with one or the other open source web browsers?

    #1300407

    I’ll give them a shot. Thanks!

    #1300409

    Tried both; same thing. I’m thinking this may be an issue with WordPress and Windows 7, which is fairly disappointing. I may just fire up my dead Linux box and try it there to confirm. It wasn’t always like this. In fact less than a month ago I had no issues at all with the button. It just started happening recently.
    The shares problem still persists though, and I know it’s not a Windows issue because other blogs I visit show the number of Facebook and Twitter shares right there in the post. Any help with that would be appreciated.

    #1300417

    meylodie
    Member

    I’m thinking this may be an issue with WordPress and Windows 7

    WordPress I don’t think so, as I was able to click on the button of your website. W7 maybe.
    If you Linux box is dead, perhaps would you need a new one? :)

    #1300445

    Well, not dead. Just not in use anymore. Even if the issue is with W7 it’s still something WordPress needs to fix. I never had this issue until recently, and I can’t imagine I’m the only one, especially since I’ve tried it on someone else’s computer. I quick search in the forums shows that I’m right:
    https://en.forums.wordpress.com/topic/like-button-not-working-2?replies=63
    https://en.forums.wordpress.com/topic/like-button-not-workingavailable?replies=1
    These are both fairly recent too.

    #1300448

    meylodie
    Member

    Hi,
    I don’t know what to tell you really, I don’t do Windows. Else, the first link you point has posts which say the people who click to the “Like” button must have an account at wordpress.com and be signed in, and the second one refers to a website where I can’t find any post, page or Like button.

    Maybe someone else will be able to help you better.

    #1300449

    timethief
    Member

    @th3prodigalson
    Please try what follows and report your results step by step.

    If you are not running one of the browsers and versions listed at http://browsehappy.com/ please try upgrading or switching first.

    Note: If you are using an IE9 browser in compatibility mode that makes it render as IE7 and IE7 is not supported. To disable see > http://www.sevenforums.com/tutorials/1196-internet-explorer-compatibility-view-turn-off.html

    If you are running one of the browsers and versions listed at http://browsehappy.com please do these four things:

    1. Try clearing your browser’s cache: http://www.google.com/support/accounts/bin/answer.py?hl=en&answer=32050

    2. Make sure that you have third-party cookies and JavaScript enabled: http://en.support.wordpress.com/third-party-cookies/
    http://www.google.com/adsense/support/bin/answer.py?answer=12654

    3. Try with all browser extensions or add-ons temporarily disabled.

    4. Try enabling HTTPS: http://en.support.wordpress.com/https/

    If it’s still happening, let us know which browser (and version of it) you’re using by checking here if necessary http://www.whatbrowser.org/ and also post any error reports you get.

    #1300450

    Thanks timethief. I saw all those suggestions in another thread and I tried each one; the issue is still not resolved. As I mentioned to meylodie I’ve also tried multiple browsers, with and without logging in, and the issue remains the same: The Like button is stuck on loading. I can’t even see likes that occurred before this issue started. I can, however, still like posts that appear in my Reader.

    None of those suggestions worked for my Share count problem either. My main browser is Internet Explorer 10, and all my versions of Chrome, Opera and Firefox are up to date.

    #1300451

    timethief
    Member

    The reason I asked for reports step by step is because I attempting to save Staff time. The thread is already tagged for their help. They cannot resolve your issue without being able to duplicate it. Please subscribe to the thread so you are notified when they respond and please be patient while waiting.

    #1300452

    Thanks. I’ll be waiting. I’m curious: are you a special kind of WordPress user? I’ve seen your name in a bunch of other threads and it seems you have the power to alert the Staff to certain issues. Is this something anyone can do, or do we have to be members for a fixed amount of time or what?

    #1300453

    timethief
    Member

    This is a peer support forum and anyone can type a modlook tag into the sidebar of a thread when Volunteers are unable to provide the required assistance. Sticky post – head of forum https://en.forums.wordpress.com/topic/wordpresscom-forums-code-of-conduct?replies=1

    After doing that one is wise to know that Staff work forward from the threads tagged for their attention with the earliest date/time stamps to the most recent date/time stamps. They have a backlog and bumping threads is counterproductive.

    #1300454

    Alright. Thanks a lot.

    #1300465

    csonnek
    Staff

    Hi there!

    I was able to reproduce your problem with the like button on your posts in Windows 7 and I alerted our developers to the issue. I will get back to you once I have more information.

    In the meantime, let me know if I can help with anything else.

    Thanks!

    #1300466

    Thanks csonnek. I’m also having problems with the little share widgets not updating when shares occur. My stats page shows that a number of my posts have been shared on Facebook and StumbleUpon, but the buttons on those posts do not reflect this. I didn’t even know sharing was happening till I stumbled on the shares stats in the stats page. Could you help with that?

The topic ‘Shares’ is closed to new replies.