sharing buttons disappeared

  • Author
    Posts
  • #1157963

    mmadfan
    Member

    The sharing buttons (email, FB, print, etc.), and the WordPress “like” button seem to have gone missing. I am viewing individual posts, and they just aren’t there.

    I’ve checked the sharing settings in the “settings” area, but everything is the way it’s always been. I looked at a post in edit mode, and the boxes are both ticked for showing the WP like and the sharing buttons, yet they aren’t appearing.

    I’m using Firefox 18.0.2.

    The blog I need help with is mmadfan.com.

    #1158055

    mmadfan
    Member

    I also noticed on my settings>sharing page that FB no longer appears as an option (to add as a sharing button to posts, not the publicize feature).

    I have checked the blog using Opera, not logged in, and I DO see the sharing buttons then. Since I always used to be able to see the sharing buttons when logged in, and since the FB sharing button is missing on my settings page, can I presume that this is a Firefox-specific issue? Anyone have any recommendations of what might fix this, if there’s something I can do on my end?

    #1158056

    timethief
    Member

    Hey there,
    I using Firefox 18.0.2 and I can see the like button and sharing icons. I don’t know why you can’t as you are using the same browser. Does this help with the Facebook sharing button? https://en.forums.wordpress.com/topic/its-possible-facebook-share-and-like-buttons-at-the-same-time-update?replies=5

    #1158057

    timethief
    Member

    All I can suggest is that you go through the complete troubleshooting drill that follows.

    If you are not running one of the browsers and versions listed at http://browsehappy.com/ please try upgrading or switching first.

    Note: If you are using an IE9 browser in compatibility mode that makes it render as IE7 and IE7 is not supported. To disable see > http://www.sevenforums.com/tutorials/1196-internet-explorer-compatibility-view-turn-off.html

    If you are running one of the browsers and versions listed at http://browsehappy.com please do these four things:

    1. Try clearing your browser’s cache:

    http://www.google.com/support/accounts/bin/answer.py?hl=en&answer=32050

    2. Make sure that you have third-party cookies enabled: http://en.support.wordpress.com/third-party-cookies/

    3. Try with all browser extensions or add-ons temporarily disabled.

    4. Try enabling HTTPS: http://en.support.wordpress.com/https/

    #1158058

    mmadfan
    Member

    Hi, timethief!

    I can’t figure it out. I even logged out (in Firefox) and looked at the posts, and the buttons aren’t appearing, then logged back in, and my “Settings>sharing” page looks strange. It’s been a while since I visited the sharing page, but I seem to recall that the little preview down at the bottom of the page that shows what buttons will appear actually shows the buttons, not just text (and I’ve chosen to have buttons, not just text, to appear on the blog).

    Thanks for the link, as well, but that’s not the problem. The FB like button that comes standard as an option in “sharing” has disappeared for me — I can’t even drag it away if I changed my mind about using it. Yet I know that it’s on the posts, since when I’m on Opera, I can see a facebook like button.

    Also, oddly, the link that I created myself for newsvine is still there on the settings>sharing page — although I don’t see its icon unless I hop onto Opera to view the page.

    I greatly prefer using Firefox for this blog, since I use Opera for administering another blog under a different email addy, and I am able to stay signed in on both browsers with two different accounts for a number of different sites.

    I did try a forced refresh, but that didn’t fix it. I haven’t done much with my blog recently because of various RL issues, so I’m a bit rusty with the possible fixes.

    Thanks!

    #1158059

    mmadfan
    Member

    Oops! didn’t see your other reply. I will go through the drill! Thank you!

    #1158060

    timethief
    Member

    I tagged this thread for Staff help.

    #1158061

    mmadfan
    Member

    Thanks, tt!

    I’ve cleared my cache, and then did a force refresh, and that didn’t help, either.

    One thing I haven’t tried is rebooting the computer, so I’ll do that, and if it’s fixed, I’ll mark this as “resolved”; if not, I’ll hope for a staff suggestion/fix.

    Thanks again!

    #1158062

    timethief
    Member

    Sometimes when all else fails rebooting or disconnecting and reconnecting your router works. My fingers are crossed for you.

    #1158077

    mmadfan
    Member

    Clearing the cache, rebooting, and forcing a refresh didn’t help in Firefox. I opened my admin pages in Chrome, and I was able to see everything as I expected to see it. It’s just in Firefox that it’s not working, apparently.

    Here are screenshots of what I see in the settings>sharing page in Firefox & in Chrome. Some of the sharing buttons are missing entirely in Firefox and none of them show the official icon, although that’s what I’ve chosen, and when I view my blog on Firefox, I don’t see any of the sharing buttons at the bottom of posts, whether I’m logged in or not.

    http://mmadfan.com/?attachment_id=6133 (Chrome Screenshot)
    http://mmadfan.com/?attachment_id=6134 (Firefox Screenshot)

    #1158078

    timethief
    Member

    I’m sorry you couldn’t resolve this. Thanks for posting the screenshots as they will be helpful for Staff.

    #1158087

    mmadfan
    Member

    I figured out what it was. Adblock Plus is identifying the sharing buttons as ads. I turned off Adblock Plus only for my domain, and the sharing buttons reappeared. (I feel as though I should have thought of this much sooner.)

    I thought I’d post the “solution” just in case someone in the future does a search on the problem & this might help them.

    It is sort of annoying to know that Adblock is blocking the sharing buttons. I know that it has not always done this, since I’ve used Firefox for my WP blogging since I began, and I have always had Adblock Plus installed and functional. Must be a change in the blocking software, I imagine.

    #1158151

    macmanx
    Staff

    Thanks for checking on that!

    Would you mind reporting the false positive to Adblock? It always seems to get done quicker when reported by the users.

    #1158154

    mmadfan
    Member

    @macmanx: Yep, will do!

    #1158155

    macmanx
    Staff

    Thanks!

    #1158160

    mmadfan
    Member

    Submitted the reports. I also noticed this time that my widget to subscribe via email and the floating “Follow” button are blocked as well.

    #1158161

    macmanx
    Staff

    Oomph, that’s annoying. :(

    Thanks for reporting those!

    #1158175

    mmadfan
    Member

    I had a little time today to explore this issue a bit more closely (after my favorite knitting site also appeared to have “lost” sharing buttons and other elements that I was used to), and I found that it is a specific filter list that is causing the sharing buttons, email subscription widget, WordPress “like” button, and the icons next to the rss subscription links to vanish.

    The “Fanboy Annoyances” filter list is nice because it does block some unwanted pop-ups, but it also blocks all of the sharing buttons — just about any links, buttons, or images related to social media sites seem to be targeted, as well as email and print buttons. Once I deleted the “Fanboy Annoyances” list, I was able to use Adblock Plus and still see all of the sharing options on WordPress blogs and elsewhere, as well as being able to see them on my WP admin area’s Sharing page.

    I think the main reason I hadn’t run into this before is that I’m on a new computer and when I added Adblock Plus to Firefox, I didn’t select filters this time, but just went with the defaults.

    I hope this is helpful to someone!

    #1158176

    macmanx
    Staff

    Thanks for letting us know!

The topic ‘sharing buttons disappeared’ is closed to new replies.