Need help? Check out our Support site, then


Sharing on Twitter

  1. I have discovered that when I share blog posts over Twitter - when they are opened on cell phones the blog (theme) format is missing. Readers are shown the standard UGLY 'reader' format. Why is this happening and how soon can this be put right? It is happening to all of the blogs I am reading... and that is not what I want. Thanks.

    The blog I need help with is randompublicjournal.com.

  2. Hi there,

    Can you please give a link to a tweet you've shared so I can check this?

    Do you have the WordPress mobile app installed? At some point you could have told your phone to always open WordPress.com links in the app instead of the browser, which would explain what you're describing. You'll need to change the default app settings on your device to stop that from happening.

  3. Hi Kokkieh - Here's a link: https://twitter.com/Butterfly_Reb/status/900231148919554048

    This opens in the reader when opened on mobile devices. When others show screen grabs (so not just me) they are images of the reader version, and I see that it is happening to other people's WP blog. I do not use the App.

    I would be over the moon if you could help me with this. Many thanks.

  4. Okay, that's not the Reader, but the AMP version of your site. AMP is a framework Google introduced some time last year that basically creates a version of your site that is optimised to load as quickly as possible on mobile devices. This framework is activated by default on all WordPress.com sites.

    Twitter recently started serving the AMP version of shared links if there's one available. Previously Twitter served the full version of the site, which is why this did not happen before.

    To stop this from happening, you'll have to disable AMP on your site. This will mean your site might not show up as much in searches via mobile devices as it currently does, as Google gives preference to sites with AMP versions in searches on mobile devices.

    You can disable AMP from My Site ->Setting ->Traffic, but it could still take a day or two before Twitter will start using the non-AMP version of your pages again. It might also help to run a few links from your site through Twitter's card validator after you've disabled AMP:

    https://cards-dev.twitter.com/validator

    You can find our support doc on what AMP is and the options that are available for it here:

    https://en.support.wordpress.com/amp-accelerated-mobile-pages/

  5. Kokkieh - Thank you. You are a legend. That's fixed now. As it is a political blog with a good following I think I can afford to skip the preferential treatment of Google.

    Since I am here, the date stamp on the site recently went pear shaped. It now loads a small date at the top of the black circle it is located in at the top left of each post (on the desk top version). Is there something I can do to put that right again?

    With loads of gratitude, Jason

  6. The time stamp looks like it might be a theme bug. Do you perhaps know when the time stamp change happened? I see there has been some recent changes to the theme, but nothing that right off the bat looks like they could have been the cause of this. Knowing the timeline would help us narrow down which change caused it, meaning we might be able to fix it a little faster.

    That said, I also noticed that your theme was retired a few weeks ago. We retire themes when they become too old to maintain because there isn't a simple way to add support to them for the newer features we introduce on WordPress.com, or because the programming languages have just evolved to a point where it isn't feasible to keep updating the theme to remain compatible with our software and the various browsers.

    You can still keep on using a retired theme, and it should still work for quite a few years, but eventually it will break and retired themes are not prioritised when it comes to bug fixes. So with that in mind, you might want to start thinking about looking for a new theme. I'll still report this bug, though.

  7. Oh no! I have just become an evolution denier. I don't like change - especially in the blog format. Okay, I will take that on board and begin looking around. Thanks.

    In terms of when this occurred, I can only say that it was about a week ago. I cannot be more exact than that. Thanks for your help.

  8. The changes I see on the theme looks like they were less than a week ago, but thanks for the information nonetheless.

    I've reported the bug to our theme developers. I'll let you know once I hear back from them.

    And I understand not wanting to change your theme. Hopefully we'll be able to fix this and you'll be able to use your current theme for a while longer :)

  9. Kokkieh - As always, you guys are pretty brilliant. Thanks very much for your time and help.

  10. It's my pleasure :)

  11. Hi there,

    I just wanted to let you know that the problem with Reddle has been fixed, though I see you've since switched to Ixion.

    Please let me know if I can help with anything else.

Topic Closed

This topic has been closed to new replies.

About this Topic