Sharing to Facebook Personal instead of business Page

  • Author
    Posts
  • #899862

    Hi,

    I have a problem with sharing my blog posts – they’re being published to my facebook personal page instead of business page.

    I have run through all the setting options, have checked the box for my business page to receive the posts, and every time I write a new post, the settings seem to reset and my posts are published to my personal facebook.

    Anyone have any ideas on how to fix this? I have disconnected and re-connected facebook and wordpress twice, and the problem persists. It’s like wordpress forgets that I’ve saved the settings to direct to my business page.

    Any help much appreciated, thanks.

    The blog I need help with is heiressflowers.com.

    #900026

    Apologies, I forgot to write my blog address.

    http://heiressflowers.com

    #900027

    raincoaster
    Member

    I suggest that you go into your personal page settings and disallow the Publicize app that shares posts to FB. Then presumably you should be able to set it to your Page rather than Profile easily.

    #900200

    Unfortunately that is not possible. You can’t disallow the app from the personal site without removing it from your pages.

    On wordpress I can select which – fb personal or business page – to post to, and select my business page every time. But when I write a new post it defaults back to the personal page.

    Is it a bug?

    #900204

    raincoaster
    Member

    Disable Publicize completely, clear your FB cache, and then try re-connecting it.

    http://umairj.com/146/how-to-clear-facebook-shares-cache/

The topic ‘Sharing to Facebook Personal instead of business Page’ is closed to new replies.