Sidebar goes to the bottom

  • Author
    Posts
  • #321036

    btemkin
    Member

    In my blog (http://experiencematters.wordpress.com), the sidebar goes to the bottom but it shows up in the right place for individual posts. Also, I get a tiny smiley face icon up at the top where the sidebar should be. I’ve isolated the problem to a January post (by looking at posts by month), but can’t seem to find the problem. I read about problems with graphics and I went through and shrunk the graphics, but that didn’t help either.

    The style is Regulus.

    Any suggestions?

    #321295

    timethief
    Member

    Hi there,
    The answers to both questions is found in the FAQs :) The tiny smiley face is an indication that your stats are being tracked. We all have one.
    When a sidebar falls it’s because we have inserted something (usually and image or copy and paste block of text) that’s too large into the blogging space. We then have to limit the number of posts on our front page to one and work posts by post backwards until we find the post with the problem and fix it. http://faq.wordpress.com/2008/05/30/why-is-my-sidebar-at-the-bottom-of-my-posts/

    #321305

    According to W3C validation, you have an open div tag somewhere (along with a few others), but I don’t have time to track it down because I’m heading out of town in just a little bit, but I’ll give you a hint on how to fix it.

    First go to settings > writing and select “WordPress should correct invalidly nested XHTML automatically” and then click save changes at the bottom of the page.

    Next, open each post on your main page in the editor, change one little thing (like adding a space and then deleting it) and then click the “update post” button. WordPress will then examine your post and fix any incorrect HTML. When done, everything should be fixed. What is causing the problem is only one missing div tag, but there are other missing tags as well and I suggest fixing those as well.

    Another suggestion is to limit the number of post shown on the blog page to say three. You have long posts, and even with my 5mb connection speed, you site takes quite a while to load. Go to settings > reading, change the number there, and then again click “save changes.”

    #321317

    Check this:

    http://faq.wordpress.com/2008/06/17/formatting-issues-with-the-more-tag/

    and correct your January 12 post.

    #321357

    btemkin
    Member

    Thanks! Changing the setting on the Settings > Writing page seems to have fixed the problem!

The topic ‘Sidebar goes to the bottom’ is closed to new replies.