"Sign up for just a username" link isn't working for me

  • Author
  • #737031


    I have set the referenced blog to Private, but want to provide a WP username for someone who doesn’t have one and isn’t interested in starting a blog at this time. However, the “sign up for just a username” link on the Sign Up page isn’t working for me. I have tried it in FF (7.01) and IE (9) on both Windows 7 and Linux. I either get a Bad Request error, or clicking the link does nothing at all. (To do so, I’m using another computer where I’m not logged into WP.)

    Any help would be appreciated. Thanks!

    The blog I need help with is gaelengreen.wordpress.com.



    Same problem here, can’t add new users to our blog because the “just a username” link is broken.



    Hi to you two. I saved the old URL that used to be there and it still works. Try:

    This being said, I tagged this thread to get staff’s attention.



    Sorry about that, we’ll get that cleared up ASAP. For now, http://en.wordpress.com/signup/?user=1 will work.



    Thanks everyone! Unfortunately, the old URL redirects to the new one, and I still get the 400/Bad Request. Any way to temporarily turn off the redirect?



    @gfgonline: It should work if you log out of WordPress.com first.



    Oops – duh!! Worked like a charm.

    Thanks again for all the fast replies!


    RE: Registering New Users

    Testing creation of new WP username only accounts has been plaguing me, too. And many others, lately, seem to have the same problem, resulting in new users not showing up in the Users list (and not landing on the page with their dashboard).

    Here’s what I discovered:

    Sometimes the the link for “sign up for just a username” doesn’t work; when clicked the page it is on just refreshes without change, whereas it should refresh whith the Blog Address input box (and other things). The problem is related to cookies for WordPress (and/or the page the Register link is on).

    Clearing cookies resolves the problem (temporarily), but eventually the problem reoccurs.

    So this is not a fix, but rather a clue as to the root of the problem which WordPress needs to resolve.

    Another problem I have is with Register on the Meta widget. Since most new users my website–and I imagine many other websites–need to register for a username only. So why not give them the correct page to start with, rather than having them notice and click the link ( “sign up for just a username”) that creates the correct page for them.

    Let’s make Register naive user-friendly.

    My workaround was to use the replace the Meta widget with a Text widget that has the correct link for Register. Unfortunately, it doesn’t fix the cookie problem, above. WordPress really needs to fix that real soon, now.



    I should have mentioned that a (naive) new user who uses the page with the Blog Address input to register a new username only account–leaving that input empty–seems to provoke the missing user problem (and eventual waiting, forever, for the user to appear in the User list.



    Hello there. I’m just letting you know I have flagged this thread for Staff attention.


    More data to consider:

    I have been using the Chrome browser during all my WordPress blog testing/development.

    When a link with https://en.wordpress.com/signup/?user=1 is used in Chrome and the link works, the full URL appears in full in Chrome’s address input field.

    However, I just tried the latest version of the Opera browser and observed that even though the correct username only page renders when a link with https://en.wordpress.com/signup/?user=1 is clicked, the URL in Opera’s address field truncates the URL to https://en.wordpress.com/signup/. Evidently, these flaky results/problems are dependent on the browser being used.



    It sounds like Opera is stripping out query strings. From that page, you can click “signup for just a username” to signup for just a username.


    Well, I can make the links with the query string WORK PROPERLY OR NOT–and so can you–and the evidence points to cookies as the culprit.

    1. Note that cookies are deleted when the Chrome browser is closed. So, close the browser and re-run it. [THis may be true for Opera, too; I just haven’t tried it.]
    2. Now try links with the /?user=1 query string appended (as for “sign up for just a username” or my modified Meta | Register link). Notice the appended query string appears in the status bar when hovered over and in the address field when clicked. And the username-only page is properly rendered.
    3. NOW, click the Site Admin link in the Meta widget, then click the link at the top of the browser to open the blog.
    4. Then proceed to find and click any link with that query string: it still appears when hovered over, but does not appear in the address field AND the username-only page IS NOT rendered; the page with the Blog Address field is rendered and continues until to be until the cookies are cleared (as when the browser is closed, or when they are manually cleared).
    5. I don’t bake cookies–only eat them–so I don’t know what’s going o–other than it’s a cookie problem–but I sure hope someone out there, hopefully at WordPress, does, and soon.



    Well, yes what you’re saying is true. You won’t be able to use https://en.wordpress.com/signup/?user=1 when you’re logged in because you’re already logged.

    You can’t create a user-only account when logged in as a user. You can only add a blog to your account, which is why it redirects to https://en.wordpress.com/signup/

The topic ‘"Sign up for just a username" link isn't working for me’ is closed to new replies.