Site Not Working

  • Author
    Posts
  • #3085885

    When I try to go to my website I am suddenly getting these errors:

    Warning: require_once(classes/class-wc-connect-extension-compatibility.php): failed to open stream: No such file or directory in /home4/hlarsen24/heatherlarsenphoto.com/wp-content/plugins/woocommerce-services/woocommerce-services.php on line 39

    Fatal error: require_once(): Failed opening required ‘classes/class-wc-connect-extension-compatibility.php’ (include_path=’.:/opt/php56/lib/php’) in /home4/hlarsen24/heatherlarsenphoto.com/wp-content/plugins/woocommerce-services/woocommerce-services.php on line 39

    This site has worked fine in the past. Any ideas on what could be wrong?

    The blog I need help with is heatherlarsenphoto.com.

    #3086010

    Hi there,

    I’m sorry, but heatherlarsenphoto.com. is not hosted at WordPress.com. As such, we are unable to provide any direct assistance in this manner.

    The fact that the site may have been built using WordPress, or may mention ‘Powered by WordPress’ (or something similar) simply means it is using the WordPress.org software, which can be downloaded and installed on any web host.

    If you’re interested, you can learn more about the difference between WordPress.com and WordPress.org here:

    http://en.support.wordpress.com/com-vs-org/

    I would recommend getting in touch with your host or domain registrar for support, or checking out these resources if your site was indeed built with WordPress software:

    http://wordpress.org/support/
    http://codex.wordpress.org/Main_Page

    To find out who is hosting your site, you can visit http://www.whoishostingthis.com

    Best,

    #3086081

    ftg2017
    Member

    It appears WooCommerce decided to rename their extension, go to the path in the Warning/Error and edit your wp-content/plugins/woocommerce-services/woocommerce-services.php

    there are a few require_once commands near the top, one will be referencing the compatibility file in your warning

    go to the classes folder next level down and you will find compatibility files, mine was class-wc-connect-compatibility.php

    rename the file insire the require_once command to match that (in my case I took out the word “extension-“)

You must be logged in to reply to this topic.