Need help? Check out our Support site, then


  1. move site do a different directory on my host site:
    I was
    now I am

    However can not connect Jet pack.

    I have tried:
    -removing and re-installing
    -At this time I do not have W3 Total Chach on site.
    -I have a account (see below)

    Here is the full error message:

    Your Jetpack has a glitch. Something went wrong that’s never supposed to happen. Guess you’re just lucky: site_id_invalid
    Try connecting again.

    Error Details: This site is already connected to

    The blog I need help with is

  2. The blog I need help with is

  3. The error says:

    This site is already connected to

    Could you please try fulling logging out of, and then try connecting to within the Jetpack interface?

    What user account are you using to connect to the site? I don't see any Jetpack sites connected to the user wagthedoguk and I'm not finding either of the above URLs in our system.

    Once we have more information we can troubleshoot further. Thanks.

  4. Hi, is my wordpress site.
    I tried as you asked.
    1. I first un-installed Jet pack on
    2. Then I un-logged myself out of
    3. re installed Jet Pack
    4. Tried to connect ...same response
    5. logged into wordpress
    6. tried to connect again...same response.

    Jetpack worked fine on

    since changing directories it does not.

  5. Hi there, it looks like the Site URL as defined under Settings > General may not be set correctly, which is causing a site ID mismatch in Jetpack.

    Could you please check what you have next to the Site URL field. What does it say?

    It should be the address where your WordPress core files reside, starting with http:// part and without a slash "/" at the end.

    Looking at your source code, that would make it:

    More info:

  6. hello,
    I checked in setting>General and found that both say they point to

    I can access my site by

    Perhaps this may be causing the problem. When I changed my account to a self host. t a year ago) I had it re-directed to Would that affect it?

    lastly not comfortable on tooling (fooling) around in my php files or data base...I am just not IT capable of that!

  7. Thanks for checking that.

    I'm going to ask the Jetpack developers to have a look at your issue and I'll keep you posted here.

  8. thanks so much! Looking forward to resolving this annoying problem!

  9. Okay I think the problem is that on my wordpress account:
    Dashboard-My blogs it says: Linked blogs - linked to
    it needs to be changed to

  10. OK, I've removed the site from your account. Please try reconnecting Jetpack to WordPress under the new URL and let me know how it goes.

  11. Arrr..... I so thought that would work. I even re-installed Jetpack, and logged out of wagtheddoguk.wordpress and tried to connect.
    I got the same error message!!!!

    Do you think there is something on the back end like in the data base or something that still pointing somewhere else?

    Very frustrating.

  12. I'm sorry that didn't work. I'm checking in with our developers again and will keep you posted.

  13. Thanks so much, its driving me crazy! I really my subscribe list and stat data!

  14. We've made a tweak at our end with your Jetpack cache - could you please try connecting again? Thanks!

  15. still the same...
    It should not be this hard.
    What can I Do?

  16. I'm sorry that didn't work. We're still investigating and I'll keep you posted.

    We noticed that you have an active site redirect on, pointing it to Is that something that you want to keep active?

  17. Thanks so much you guys! I really appreciate it.
    I did the redirect about a year ago when I became self hosted and bought my domain. I don't see in my stats any of the redirects, so I guess I could drop it now. Thx

  18. I've removed the redirect - would you mind trying to connect again and let me know?

    I'll still keep you posted on our investigation.

  19. Okay.
    I always re-install jetpack and log out of wordpress.
    Then re-install
    I now get this: site_id_invalid
    Try connecting again.Error Details: This site is already connected to
    and this: site_inaccessible

    Error Details: The Jetpack server was unable to communicate with your site [IXR -32300: transport error: http_request_failed Couldn't resolve host '

  20. Thank you - I've passed this along to the developers.

  21. Thank you for your patience. Could you please try connecting once again and let us know how it goes? You don't need to reinstall Jetpack. Thank you!

  22. Sorry for the delay...
    Tried and...
    Your Jetpack has a glitch. Something went wrong that’s never supposed to happen. Guess you’re just lucky: site_id_invalid
    Try connecting again.

    Error Details: This site is already connected to
    It's getting really strange no?

  23. Thanks for letting me know, I've let the developers know that didn't work. I'm sorry we haven't found a solution yet.

  24. Our developers have asked if you could please try these steps:

    - turn off all other plugins besides Jetpack, especially caching plugins
    - activate a default theme - like Twenty Twelve, Twenty Eleven, or Twenty Ten
    - connect Jetpack

    Let me know how it goes.

  25. Did exactly like you said... and got the same old response... already installed. I did this after the jetpack upgrade.
    This is crazy!

  26. I'm so sorry this is still happening. Our developer is still looking for the cause but has not given up! Thank you for your patience.

  27. Would you mind trying to connect again? A patch has been put into place that may fix the issue - thanks.

  28. Sorry for the delay, I have been flying around...
    So I tried again and got: is currently having problems and is unable to fuel up your Jetpack. Please try again later.

    Error Details: 500

  29. Thanks for the error report - I've let the developer know so they can investigate. Very sorry that didn't work.

  30. Our developer has tweaked the patch - could you please try connecting again? Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.