Sketch Theme Menu/Pages Display

  • Author
    Posts
  • #2003954

    Hi,

    I’m using the Sketch theme and I’d like my pages in my custom menu to appear in a straight line one after the other at the top of the site, exactly as shown on the images on the Sketch theme info page in the WP themes directory.

    Currently the custom menu only appears on the front page of my site by clicking on a button on the top right called “MENU” but I want it to appear exactly as it does in the screenshot image under Custom Menu on the Sketch theme info page.

    How can I do this or is it only possible with the Custom Design package?

    Thanks so much for your help in advance.

    The blog I need help with is clararayrusinekklein.wordpress.com.

    #2004066

    I am using the sketch theme as well and have a similar problem…but as far as the menu goes, here is a link to the Sketch theme information: http://theme.wordpress.com/themes/sketch/

    To get it in a line as per the screen shot, Go to appearance, then menus and order your pages as you want them. Sorry if this is not the info you need.

    If anyone can help with my issue: I want my Portfolio page to be the first page that appears when someone clicks on my page and I want my Blog (custom page) to be separate. I cannot seem to do this as my Portfolio page comes up as my Blog page – I have gone to Reading and -select- Front Page/Post Page, but it is not working for me.

    Any assistance is most welcome !
    Cheers
    Elizabeth

    #2004067

    timethief
    Member

    Consult the detailed theme description page
    http://en.wordpress.com/themes/sketch/

    Custom Menu
    Sketch includes one Custom Menu in the header, which can be configured by going to Appearance → Menus

    #2004069

    timethief
    Member

    See also “Portfolio Page Template” on the same page http://en.wordpress.com/themes/sketch/
    This template will display your portfolio and allow you to set your portfolio as the site’s front page.”

    #2004074

    Hi Timethief, Thanks for your feedback. I have set my portfolio as the sites front page but I cannot get the custom page (Home or Blog) to display as a blog/post page. Can you help? Thanks Elizabeth

    #2004075

    timethief
    Member

    Creating a static front page requires creating two pages and properly designating both of them. You can create a static front page called for example “Welcome” for your site and a “Blog” page for posts. To do that create two pages first http://en.support.wordpress.com/pages/

    After you do that you go to > Settings > Reading and make the designation change and click “save changes”.
    http://en.support.wordpress.com/pages/front-page/

    A static page (select below)
    Front page:
    Posts page:

    #2004081

    Hi Timethief, Thanks for your feedback. I have set my portfolio as the sites front page but I cannot get the custom page (Home or Blog) to display as a blog/post page. Can you help? Thanks Elizabeth

    #2004082

    timethief
    Member

    I’ll tag this thread for a Themes Staff follow-up. Please subscribe to the thread so you are notified when they respond and please be patient while waiting.

    #2004084

    Hi TT again, sorry, I re-clicked my previous comment (above).

    Apparently I can add posts to a page as categories, but how do I make my custom post page work with the portfolio page being the sites front page?
    My site is:
    http://elizabethkerrydesign.com/

    My screen shows that my portfolio page and my custom blog page are the same but I have a separate blog (custom page) that will not show up on screen.
    When I go to Reading, and create my portfolio page as static, it will not allow me to allocate my post page???

    Sorry if I am being a pain. I really have tried everything :)
    Elizabeth

    #2004086

    Hi again TT,
    I have just converted my ‘blog page’ to ‘categories’ in the Menu and this seems to work. It just means that I do not have a ‘custom posts page’ any more.
    Many thanks for your help,
    Elizabeth

    #2004093

    What I’m talking about is this exactly.

    I want my menu items(i.e. the pages) to be visible exactly in a straight line at the top of the site like in this image and in this image.

    I don’t want my menu items to only be visible after clicking on a big menu button at the right of my site, I want them to be visible immediately when one enters the site.

    To get it in a line as per the screen shot, Go to appearance, then menus and order your pages as you want them.

    Yes I know, I’ve already done that and all the pages still appear only after clicking on the big menu button, not in a straight line at the top as separate items.

    I’ve looked at the relevant support documents about menus and I’ve looked at the Sketch theme’s page but I still can’t get it to appear as in the images I linked to, all in one line one after the other at the top of the site.

    I really appreciate your time and help in advance.

    #2004222

    Hi WordPress team,
    I’ve also experienced a similar menu issue. In the past this has been because there were too many categories to list in the header, however in this case I only had one page “about” and it was still being displayed as a sub under Menu.

    If you could please let me know how to fix it that would be great.
    Cheers

    #2004251

    amightywp
    Member

    Hi Clara,

    I went ahead and created a new menu for you in your blog using sub-items, which is how the demo site for the Sketch theme was created. You can find it in your Dashboard under Appearance >> Menu. I titled it “Happiness Engineer.” You can try temporarily activating it under the “Manage Locations” tab. See if it works for you, and then go off of that design to customize it.

    Here is more information about custom menus:

    http://en.support.wordpress.com/menus/

    @elizabeth,

    I took a look at your site as well, and it looks like you have everything set up right to have a home page for your Template. In order to have a page for your blog entries (which will only display your posts, nothing else), you just need to create an entirely blank page with a default template and title it something like “Blog”. Save that and then set that as your Posts Page in Settings >> Reading and then click Update. You can then link to that page in your Menu and it should work just fine.

    Let me know if you run in to any problems.

    #2004262

    Hi @amightywp,

    I appreciate your time and your efforts, but that really doesn’t work at all for what I want to have happen on my site, and really wasn’t what I needed or meant at all, though I appreciate you taking the time to respond.

    I was never interested in having another menu or having sub items, my original menu’s just fine.

    What I wanted was all the menu items appearing in a straight horizontal line one after the other at the top of the site as you can see in the images I linked to from the theme demo.

    Others are asking the same question in other threads here:

    https://en.forums.wordpress.com/topic/sketch-theme-menu?replies=2

    I got an answer several days ago by asking Caroline (the original creator of the Sketch theme) on the original post that announced the new Sketch theme here:

    http://en.blog.wordpress.com/2014/08/14/new-theme-sketch/

    (See the comments on that post for anybody that might be looking for an answer to the same question that I had, and it seems that others are having too.)

    According to the answer I got from Caroline, it seems that the menu items will only appear in a straight line at the top of the site if your screen size is bigger than 1280 pixels, and for anything smaller than 1280 the only way to get them to appear in a straight line is with the Custom Design package.

    However I don’t want to and can’t (and wouldn’t even if I could) pay for the Custom Design package (and wouldn’t be able to code what I want in CSS anyway even if I did have the Custom Design package), and I have a smaller screen size it seems, so it seems my menu items will always just appear behind a menu button instead of in a straight line, unless I look at my site on a computer with a larger screen, unfortunately.

    #2004263

    Hi Clara,

    Thanks for the clarification.

    But I am hugely disappointed, I really liked the theme but can’t use it since I have huge list of nested menu items which will never work in this new type of menu.

    Hope they make add this option in near future

    #2004264

    @strategyoftaha

    You’re welcome.

    I’m really disappointed too I guess, but its not the end of the world, I can always find a new theme if it comes to that. I really liked the Sketch theme too when I first saw it. Now maybe not so much. Its still a nice theme though, too bad about the whole menu thing.

    It’d be really nice if displaying menu items in a straight line instead of under a menu button (for smaller screen sizes) is added as an option in the future but knowing WordPress I have zero hope of that happening, unfortunately.

    #2004279

    Thank You amightywp happiness engineer, I followed your instructions and guess what? It worked ha ha !
    I purchased the Port theme, but for the life of me I cannot get it to set up as per the demo. Thus, I used sketch theme, which I am quite happy with, but if you can help me set up Port, I would like to use this theme. TY so much Eliza.

    #2004280

    amightywp
    Member

    Hi again @elizabeth,

    Port is one of our Premium themes, so that means that there is a whole support page dedicated to how to use a lot of the features, did you happen to see it?

    http://theme.wordpress.com/themes/port/support/

    And if you still can’t make it work quite right, there is also a forum which is managed by the theme author. They can probably help you with any questions you might have:

    http://premium-themes.forums.wordpress.com/forum/port

    If you still aren’t happy with it, if it’s within the first 30 days of purchase, let me know and I can cancel it and refund you for the purchase cost.

    #2004281

    Hi again amightywp – Thanks for the info. I purchased Port, tried to use, cancelled it and I was sent a link to cancel the theme, but the link did not work (last week) so I thought I would give it one last shot. I have activated the theme, and so far I have been able to set up the portfolio page, but if I click on the slider menu and click on say, client page, I cannot create nice little portfolio boxes on this page. I have read and read, read, read the links you sent me but I cannot work it out. Cheers, Eliza

    #2004282

    Hi again, again amightywp, I have been trying to work on Port theme for hours now and I just cant get it. Can I get a refund on Port and Photographer, (I requested this a month back) and try the Creative Collective theme?
    Is that possible as the CC theme supports the photographs I need to put up and the portfolio page. Thanks for your considerations.
    The links I clicked on – from the email/s sent to me – to cancel are:
    Hi,
    Please confirm you would like to cancel the following premium theme:
    Port
    Purchased 16th July, Cancelled 21st July – but the link did not cancel
    and

    Hi,
    Please confirm you would like to cancel the following premium theme:
    Photographer
    Purchased 17th/07/2014 Cancelled 18/07/2014 but it did not cancel.
    Cheers,
    Eliza

The topic ‘Sketch Theme Menu/Pages Display’ is closed to new replies.