Slider not working

  • Author
    Posts
  • #1834941

    Hi. Three days ago my slider disappeared and has not appeared since. It had been working well for about one year. My theme is customized Superhero. I have not been making new customizations or layout changes

    The blog I need help with is songsofhope883.com.

    #1835036

    timethief
    Member

    What follows applies only to the free hosted WordPress.COM version of the Superhero theme. Note that ins order for featured post sliders to operate one must adhere strictly to the exact dimensions of the featured images required by the theme.

    Please consult the theme description here. http://theme.wordpress.com/themes/superhero/

    Superhero features a Custom Header that can be set under Appearance → Header. However, many bloggers assume the featured Featured Content Section at the top is the header when it is not. You are confused. Superhero does not have a full width header image. The full width images are in the featured post slider.

    Superhero header > Dashboard > Appearance > Header
    Suggested width for the header image is 480 pixels. Suggested height is 150 pixels. http://theme.wordpress.com/themes/superhero/

    If you want to have featured images in posts appearing in the featured post slider across the top of the blog then you have to set featured images. Have you read the theme description at “Featured Content Section” here? http://theme.wordpress.com/themes/superhero/

    You need to Create a post with a featured image that’s at least 960px wide, set it as a featured image and give the featured post the tag you declared under Settings → Reading → Featured Content.
    http://en.support.wordpress.com/featured-images/#setting-a-featured-image

    If you don’t see the Featured Image module on your Add New or Edit Post page, please make sure you’ve selected Featured Image in your Screen Options. If you don’t see the Featured Image module on your Add New or Edit Post page, please make sure you’ve selected Featured Image in your Screen Options.
    http://en.support.wordpress.com/screen-options

    #1835037

    timethief
    Member

    The Featured Content image size is at least 960 wide.
    Individual post featured image is at least 645 wide. http://theme.wordpress.com/themes/superhero/

    #1835118

    Thank you timethief. I follow your very good blog. Yes my Featured Content pictures for the slider are 960 x 300 pixels and they have been working very well for about one year in a slider. The slider stopped working all of a sudden 3 days ago.

    #1835146

    timethief
    Member

    That’s frustrating for sure. I’ll tag this thread for a Staff follow-up. Please subscribe to the thread so you are notified when they respond and please be patient while waiting.

    #1835164

    A solution! Slider now works. I went to
    Settings – Reading – Featured content
    to check the slider tag I was using.

    But on that page was the message “The settings for Featured Content have moved to Appearance → Customize.” So WordPress have changed the location for setting the slider tag.

    When I went to Appearance – Customize, there was no slider tag set. The tag I was using was gone. So I re-entered my slider tag and the tag now works.

    My question is “Why didn’t WordPress tell me they were changing the slider tag entry point and that I would have to re-define it?” It would have saved me all this hassle.

    #1835165

    timethief
    Member

    Aha! Thanks for the update and good on your for being so persistent. Good question BTW. I’ll leave the tag up so Staff update as you suggest.

    #1835195

    kathrynwp
    Staff

    Hi there – I’m not sure why your featured-content tag went missing, sorry about that. As far as I can see, we didn’t intentionally make any changes that should have deleted your tag.

    I’m glad your slider is up and running again and sorry for the glitch! If it happens again, please let us know and we’ll dig deeper.

    #1835211

    OK. Nice to have a problem solved.

    #1835215

    Not quite solved.
    Later on 16 May, I went into dashboard:
    Settings/Reading and made a change to the number of posts per page and clicked save.
    The slider had disappeared again. And when I checked:
    Appearance/Customize/Featured content, my slider tag had vanished!!
    The solution was to re-enter my slider tag again and the slider re-appeared.

    It seems that going into dashboard Settings/Reading, deletes my slider tag!! This needs to be fixed up by your dashboard people.

    #1835239

    kathrynwp
    Staff

    Thank you so much for letting me know the steps that caused this bug! I was able to replicate it and will let our developers know so they can get it fixed.

    #1835250

    @kathrynwp
    Hi Kathryn. Its almost 3 weeks now since this bug was identified and this bug is still present. When do you expect it to be fixed?

    #1835251

    kathrynwp
    Staff

    Thanks for checking in on the bug report. Our developers haven’t yet resolved the issue as it’s not a simple fix, but I’ll keep you posted here. I’ve asked them to have another look.

    #1835252

    kathrynwp
    Staff

    I just wanted to follow up and let you know that this issue isn’t theme-specific, and has to do with the featured-content functionality throughout all of WordPress. You can follow progress on the public ticket here if you like:

    https://github.com/Automattic/jetpack/pull/683

    Thanks for your patience.

    #1835253

    kathrynwp
    Staff

    Hi there – this bug has been fixed. Thanks for your patience and thanks again for the initial report. If anything still looks amiss, just let us know.

The topic ‘Slider not working’ is closed to new replies.