Small Twitter Issue After Purchasing New Domain

  • Author
    Posts
  • #1351174

    futbolpulse
    Member

    Hello,

    I purchased a custom domain in November and changed the default URL from thesoccerplanet.wordpress.com to futbolpulse.com. There haven’t been any issues, but whenever I post a new article and it automatically shows up on twitter (publicize), it appears without any picture or preview, only like a regular tweet.

    Here are 2 examples of tweets with a link to any WordPress article that shows up with the picture/preview I’m talking about:

    1. https://twitter.com/wordpressdotcom/status/355718840933556224 2. https://twitter.com/wordpressdotcom/status/355342357387935744

    Here is what the tweet with a link to my new article looks like:

    Is there any way to make the tweets with a link to my article appear with the picture/preview that appears with the 2 examples I have given?

    Thanks!

    The blog I need help with is futbolpulse.com.

    #1351276

    In order for the picture to show up, it must be set as a Featured Image and be at least 200×200 pixels (it appears that, at least in the blog post you mentioned in that tweet, the images are all inserted directly into the content, rather than featured.)

    Take a look at the following support articles for more info:

    http://en.support.wordpress.com/publicize/
    http://en.support.wordpress.com/featured-images/

    #1351280

    futbolpulse
    Member

    Thanks for the reply! Unfortunately, I would use featured images, but I don’t because it makes that image appear at the top of the post, which I dislike. As a result, I only use them so that they appear in the slider on my blog.

    Is there any way to prevent featured images from showing up on top of the post so that the link still appears with a preview on twitter?

    #1351281

    You could use a bit of Custom CSS to hide them:

    .attachment-large-feature {
        display: none;
    }

    That would hide them from those posts that you have in the slider, too.

    #1351491

    futbolpulse
    Member

    I got the CSS Upgrade and used that code to hide the featured images, thanks! Unfortunately, the tweet with the link to the post is still not showing a preview in twitter.

    Here is the link to my post and here is the tweet I sent out with this link.

    If you could fix this problem and make the preview show up on twitter that would be great! Thanks!

    #1351492

    Hmm, I’ve flagged this thread for Staff assistance. Please subscribe to this thread if you haven’t already, and be patient while waiting for a staff member to assist you.

    #1351493

    kardotim
    Member

    Does this issue occur on every post? or just a few? and what happens if you manually add the post link to Twitter?

    #1351494

    futbolpulse
    Member

    The issue occurs in every post, both automatically through Publicize and manually.

    #1351495

    kardotim
    Member

    You can follow these steps to allow these thumbnails to show:

    1: Go to https://dev.twitter.com/docs/cards/validation/validator
    2: Sign in, run your domain against the validator and “apply” for it
    3: Publish another post and see if it works now

    Please let us know if you need any further assistance!

    #1351496

    futbolpulse
    Member

    I did that, but now it is doing a photo rather than a summary.

    Here is the link to one of my tweets with the “Photo” summary. Here is what I want the summary to look like.

    Other than that, I want it to say futbolpulse.com with my logo rather than wordpress.com with the wordpress logo, I want the By FutbolPulse @futbolpulse removed, I want the photo to be smaller like in the example, and I want a small text summary.

    Please help me achieve this, and thank you for all your help!

    #1351497

    kardotim
    Member

    Did you manually tweeted that post or used publicize for that?

    Thank you.

    #1351498

    futbolpulse
    Member

    It happens in both. When I clicked on the link you gave me earlier, it told me I had to validate futbolpulse.com, and the only option there was a photo summary, and I couldn’t change it. It says if I want a different format, I have to do it again, but I doesn’t seem to let me validate it again.

    #1351499

    kardotim
    Member

    There should be way more type options while validating the site. There are more outstanding issues with the Twitter Validator. Please post this issue at https://dev.twitter.com/discussions/twitter-cards

    #1351500

    futbolpulse
    Member

    Posted the issue, thanks.

    #1351501

    kardotim
    Member

    Thank you. Feel free to contact us if you have any other questions.

The topic ‘Small Twitter Issue After Purchasing New Domain’ is closed to new replies.