Social media link- pinterest

  • Author
    Posts
  • #3058244

    xemlou
    Member

    Hi ,
    I’m trying to add a link for my Pinterest to my page. I’ve copied and pasted in the URL but the icon isn’t showing up. Any idea on why?

    The blog I need help with is talkingforfreedom.wordpress.com.

    #3058387

    Hi there,

    I have looked in to your site and found that you’re using https://www.pinterest.co.uk/emlouiiii/ link in your social icons widget to link your Pinterest page.

    Please try using .com instead of .co.uk in your URL and WordPress will generate the icon automatically.
    You account url should be: https://www.pinterest.com/emlouiiii/

    Please note there will no difference in the landing page as both URL is redirecting to your account.

    Let me know if you have more questions.

    #3058615

    mommalikeme
    Member

    Hi! I’m trying to Pin from my WordPress – http://www.mommalikeme.wordpress.com but don’t know how to do this, any advice? Using the Dara theme.

    Thank you!

    #3058664

    plukah
    Member

    Hi, I’m having exactly the same issue as mommalikeme. (In the link mommalikeme gives the Pinterest button is under ‘more’). There is a Pinterest button (added via the ‘sharing’ menu), and after pressing it there is a pop-up with the images to pin. However, after choosing an image and pressing ‘save’ Pinterest moves to this page: https://nl.pinterest.com/pin/find/ (empty URL).
    I’ve ask the Pinterst helpdesk, which refers me to their online manual. I’ve tried to manually add buttons in their way, but also those continue pointing to the link above.
    Anyone an idea what the issue is with this?
    Thanks in advance!

    #3058665

    timethief
    Member

    The only code that will work for Pinterest site verification of a wordpress.com blog is described here https://en.support.wordpress.com/webmaster-tools/#pinterest-site-verification and you must be logged into Pinterest when you are trying to verify?

    The Pinterest “Pin It” hover button will automatically appear on your WordPress.com blog if you have added Pinterest as a sharing button on your Settings > Sharing page and if you are also using the “Official buttons” for the style of the buttons (you can change it on that same settings page). https://en.support.wordpress.com/sharing/

    We can hover over any image in a post and pin it if we are logged into Pinterest. If you have enabled the official buttons for sharing, a “Pin It” hover button will automatically appear for your images. https://en.support.wordpress.com/sharing/ All we do after clicking the share button is choose one of the images displayed in the post to pin.

    See how to install the Pinterest browser button:
    Google Chrome
    Mozilla Firefox
    Internet Explorer
    Safari
    Microsoft Edge
    https://help.pinterest.com/en/articles/add-pinterest-browser-button#Web

    Also, note that you can embed from Pinterest https://en.support.wordpress.com/embed-from-pinterest/
    And here’s the Sharing link https://en.support.wordpress.com/sharing/

    Rich Pins aren’t officially supported by WordPress.COM a workaround is here https://en.forums.wordpress.com/topic/pinterest-rich-pin-validator?replies=5#post-2904553

    #3058666

    plukah
    Member

    Dear Timethief,

    Thanks for taking the time to respond. However, you don’t really respond to my question.
    You explain how to validate my site, how to create pins with/without hovering and how to embed. But my issue is that I have pins, but they don’t work! The buttons are showing when hoovering, and there is a pinterest pop up when clicking on them, but after selecting a pin and clicking ‘save’ pin, they all go here: https://nl.pinterest.com/pin/find/

    Might someone know what the issue is, thanks!

    #3058668

    darciemg
    Member

    @plukah, that’s definitely a Pinterest issue. I can’t make that happen on my end, and I get the correct link to save. That appears more like nl.pinterest.com/pin/create/button/… for me. The /pin/find/ is generally when you enter a URL to the + sign on Pinterest instead.

    You’re doing that from a computer and not a mobile device? Sharing from a mobile to Pinterest should use the app most of the time.

    All Pinterest help replies with an automated reply first. You’ll want to reply there again to get a person. Screenshots or videos help! I help them with support too, and suggest going back to that route to solve this problem. That’s not related to the button if you’re using one built in to WordPress.com. That’s definitely not related to the OP about a social link. :)

    #3058670

    plukah
    Member

    Dear @darciemg,

    Thank you so much!
    When you wrote you could’t reproduce it at your end and asked about my device I realized that I had tried two different browsers on my laptop, but not another device. Installed the Pinterest app, and could directly pin from my site, using the WordPress built in Pinterest button.
    So the pin button is fine and working!
    Usually I can pin using my laptop, so it is not blocking it or so.

    Anyway, I’ll try to find out at Pinterest what is going on, but my main concern (I did not install the button correctly) is not the case.
    Thanks a lot again!

The topic ‘Social media link- pinterest’ is closed to new replies.