Some users cannot comment (including myself if I am logged out)

  • Author
    Posts
  • #3020378

    fivezero
    Member

    Hello! It has come to my attention from a fellow blogger that she (and perhaps others, too) can no longer comment on my blog posts.

    She says it’s just my blog, not other WordPress blogs. I can comment myself, and others comment, too, but I have noticed fewer comments than usual.

    I tried commenting on my blog on two other browsers (where I’m not logged in) and I cannot comment on my blog posts. The submit button just does not do anything.

    On Firefox (Mac) I get the following error in the web developer JavaScript console:

    “Error: Permission denied to access property “nodeName” 725X1342.skimlinks.js:79:362″

    I don’t know if this is related, but it’s the only error that shows up.

    I have tried removing widgets (like Twitter and Instagram that call on external sources), and tried changing themes, but the problem still exists.

    Can anyone please help?

    Many thanks,
    Chris

    The blog I need help with is blog.fivezero.ca.

    #3020564

    fivezero
    Member

    OK, I don’t know what’s up but suddenly everything is working. I updated Firefox and a comment worked. I tried Safari without updating, and it also worked.

    I swear it wasn’t before!

    I’m also getting very different JS console errors, but at least the comments are now working.

    So, please disregard…thanks.

    #3020565

    jag24fps
    Member

    Hi Chris,

    It looks like we’ve both been doing some testing, and comments are appearing as they should be. Is the issue still persisting? If yes, how so?

    #3020566

    jag24fps
    Member

    Looks like we posted at the same time :)

    Glad to hear the comments are up and running!

    If you encounter any other issues, please feel free to check back in and let us know.

    #3020567

    fivezero
    Member

    Hi jag24fps,

    Thank you for trying to help me out!

    As I posted above, not sure what happened but suddenly after an hour of my trying to figure out this problem, it started to work again. I’ll see if that other blogger can post a comment, later.

    #3020568

    scifiknux
    Member

    Hey there @fivezero you may want to check your settings on your WordPress site and for your individual posts.

    You can check your settings by going to Dashboard > Settings > Discussion and make sure the box is checked next to “Allow People to Post Comment on New Articles”. You can also decide if you want to make users provide a name and email to post comments.

    Next you want to look at your most recent posts. Go to Edit, and check at the bottom and make sure “Allow Comments” is checked.

    After you’ve verified this, check with your blogging friend to see if that fixes the problem for her. If not, we’ll dig a little deeper. She may need to clear her cache as well.

    Sidebar: Here is a quick guide on how to clear your cache on Firefox for Mac: https://kb.wisc.edu/helpdesk/page.php?id=36150

    Hope this helps!

    #3020569

    scifiknux
    Member

    Whoops. Looks like I took too long to write a reply. Cheers!

    #3020570

    taranwanders
    Member

    Hi Chris!

    The error seems to relate to the Skimlinks script. If this is something that you have recently attempted to install then that may be the culprit.

    It seems a few of us were looking at this but I thought I’d toss this out there so you can possibly check with Skimlinks to see if they had any issues that caused this outage for you.

    Good Luck.

    #3020571

    fivezero
    Member

    scifiknux: Haha, that has happened to me many a time! Thanks.

    taranwanders: I don’t believe I’ve installed anything lately, so I don’t know where Skimlinks might be coming from. Looks like Skimlinks is a monetization platform; is it something WP installs by default?

    #3020647

    taranwanders
    Member

    Hi fivezero,

    Yes as it turns out, skimlinks is an affiliate. It’s part of how we keep our free services free. If your blog gets high traffic it may have ads placed. If you have. A paid plan you can opt out of that. https://en.support.wordpress.com/no-ads

    The good thing is that the feature just monetizes links but does not affect your site in any other way.

    Hope that helped, sorry for the confusion earlier.

    Cheers!

The topic ‘Some users cannot comment (including myself if I am logged out)’ is closed to new replies.