Need help? Check out our Support site, then

Soundcloud Audio Player Not Working

  1. I tried to embed a soundcloud player ( in either a text widget or a page, but both attempts resulted in the audio player not playing, when you press 'Play'. It worked once, but then I edited the playlist and changed the code and now it doesn't work...
    I will try again and again but for now I had to ask for some help!
    Thanks in advance.

    The blog I need help with is

  2. I am really confused because it works in the first place but then when I edit it, it suddenly starts to malfunction!!! Help please.

  3. Hello? Please can someone help?!

  4. Sometimes it works and sometimes not however there is no clear pattern to this! Aaaaaarrrrrrgggggghhhhh!

  5. Please. I'm struggling to be patient because i really need help - it feels like every other topic is getting support but me!

  6. This is just to let you know that we Volunteers do not post into any thread unless we know we have a correct answer we can provide.

  7. Ok sorry but I just need any tips perhaps! Any guesses? Anything will help!

  8. I've seen the link but am still struggling!

  9. You could tag it up for support but they are away, right?

  10. P.S. The soundcloud music player on your blog in your sidebar works for me. That suggests you have either a browser issue or a connectivity issue.

    1. If you are not running one of the browsers and versions listed at please try upgrading or switching first.

    2. If you are using an IE browser in compatibility mode please disable that mode.

    3. If you are running one of the browsers and versions listed at

    (a) Try clearing your browser’s cache

    If applicable see here for instructions on how to clear the cache for Chrome and Safari on the iPad:

    (b) Make sure that you have both third-party cookies enabled and JavaScript enabled

    (c) Disable all browser extensions or add-ons temporarily.

    (d) Try enabling HTTPS:

    Add both * and * to your list of trusted sites under the Security tab. Make sure to uncheck the box for “Require server verification (https:) for all sites in this zone.”

    4. Try using another browser.

    5. If you are not successful let us know:
    (a) Exactly what kind of device you are using to connect to the internet and to
    (b) Exactly which browser (and version of it) you’re using by checking here if necessary
    (c) And what any error reports you receive state.

  11. Well, it currently works when I use chrome for iPod Touch, however I will check when I next access the computer what happens, as I use IE but it is often faulty. As I do not own the computer, I do not know to what extent I will be able to follow those instructions, but for now, it really helps. Thanks so much, and be sure to stop by at my blog again!

  12. IE bowsers can be problematic and even more so if the blogger enables compatibility view or chooses to use private browsing settings. Sorry I can't be of more help on this. On the up side here are the browser share stats so you can see how few actually use IE.
    Note also >

  13. Thanks again for everything!

  14. You're welcome and best wishes.

  15. You are a genius...

  16. Hiya. I tried EVERYTHING, but I was forced to use another browser, which worked fine. Is there a way to get it to work at all on IE, as I can't get all my IE bloggers to change!

Topic Closed

This topic has been closed to new replies.

About this Topic