Source code styling

  • Author
    Posts
  • #1250981

    passiondev
    Member

    Hi all,

    I just discovered that the sourcecode on my blog isn’t styled correctly anymore. I haven’t changed the posts in anyway and it was styled correctly in the past.

    The problem appears in Chrome as well as FireFox and IE. For about a second the grey hightling box is shown after it disappears again.

    I use [sourcecode language="csharp"] [/sourcecode] to mark content that is sourcecode.

    Could someone please point me in a direction how to fix this issue.

    Thank you

    The blog I need help with is passiondev.wordpress.com.

    #1251184

    timethief
    Member

    What I know about writing source code and posting source code would be lonely on the head of a pin. http://en.support.wordpress.com/code/posting-source-code/ I have tagged this thread for Staff assistance. Please subscribe to the thread so your are notified when they respond.

    #1251205

    macmanx
    Staff

    It’s working just fine for me.

    The grey box will appear for a few seconds while the syntax highlighter library is loaded.

    First, please make sure that your browser is up to date by visiting http://whatbrowser.org/

    If it is not, please try updating your browser or switching to a different browser.

    If it is, please do these four things:

    1. Try clearing your browser’s cache and cookies: http://en.support.wordpress.com/browser-issues/

    2. Make sure that you have third-party cookies enabled: http://en.support.wordpress.com/third-party-cookies/

    3. Try with all browser extensions or add-ons temporarily disabled.

    4. Try enabling HTTPS: http://en.support.wordpress.com/https/

    Please let us know how each step goes for you, and which browser (and version of) you’re using if you’re still having trouble.

    #1251264

    passiondev
    Member

    Hi,

    thank you for your replies. I’m a bit confused that it’s working with your browser.
    Are the line numbers shown? I’m using Chrome at version 26 but tried it with Firefox and IE as well.

    I can’t see any linenumbers except a zero before the last line.

    This really annoys me since my blog is about code. :-(

    Regards

    #1251270

    macmanx
    Staff

    You are absolutely right about the line numbers, I hadn’t noticed.

    We’re looking into this.

    #1251272

    Hi,

    It was an issue with the specific theme you were using (it was hiding the line numbers by mistake). We’ve made a fix to the theme and line numbers should be showing up one again for you.

    Thanks for the bug report!

    #1251277

    passiondev
    Member

    Hi,

    thank you very much for this quick solution.

    It’s all beautiful again. ;-)

    Thanxs again!!!

The topic ‘Source code styling’ is closed to new replies.