Space not appearing above and below one paragraph, when I publish

  • Author
    Posts
  • #1077959

    brianat9
    Member

    I’m new to this! Somehow the space above and below a particular paragraph dissapears when saved/published. I’ve tried inserting single spaces to compensate ( and saving the change ) but this doesn’t appear either. Any suggestions please?

    The blog I need help with is animistjottings.wordpress.com.

    #1078059

    Blog editors and word processors are not the same and do not work the same way. The web standard is one blank line only, so you cannot add more blank lines by pressing return repeatedly like you would do with a typewriter or in a word processing application. If you want to learn how to format and space your posts and pages see:
    http://en.support.wordpress.com/writing-and-formatting-poetry/

    If you are working in the Visual editor, to get single spacing between paragraphs hold the SHIFT key down and simultaneously click ENTER at the end of the paragraph.

    If you are working in the HTML (Text) editor, a single click of ENTER will give you a single-spaced line, and two clicks of ENTER will result in double spaced lines. http://onecoolsitebloggingtips.com/2011/09/13/wordpress-formatting-and-spacing/

    P.S. When you create a new post, always make sure the Format tool is set to Paragraph before you start typing. It’s in the Visual editor Row 2 first position “style”. See the illustration here http://en.support.wordpress.com/visual-editor/#row-2 If you forget to do that then edit the post, highlight all in the Visual editor, select Paragraph from the Format tool, switch editor to Text then switch back to Visual and click Update.

    #1078117

    brianat9
    Member

    Thanks for this. I was entering single spaces as you say ( using shift and enter ) but the space only appeared in visual editor, not in my new published page.

    I’ve now tried setting the Format tool to paragraph ( four pages have been o.k without doing this? ) but this too has had no effect on the published page.

    The problem page is called “Birds, Liminality and Transformation”, and the problem paragraph ( no space shows before or after it ) is the one above the second photograph.

    I hope there’s something else I can try?

    #1078119

    brianat9
    Member

    Posscript. I may have stumbled on the solution. I went into ‘text’ edit, for the first time, and removed a couple of surplus <div> ‘s. This has restored the space above the paragraph. I’m not familiar enough yet with text editing to see what the problem is between the bottom of the paragraph and the image.

    Thanks again for the suggestions, and indeed for any further ideas.

    #1078121

    brianat9
    Member

    Hurrah! I looked at a successfully spaced image in text mode and spotted the layout error. Once again removed a couple of surplus <div> ‘s and this did the trick.

    Phew!

    #1078123

    Yay! I’m so glad to hear that good news. Best wishes with your blog.

    #1078164

    justpi
    Member

    @btaylor679: Setting the Format tool to Paragraph is what you must observe when you start a new post or page (if you don’t, you get the div tags you found out). For an already published post or page, merely selecting Paragraph won’t change anything: you have to highlight all, select Paragraph, switch the editor to Text and back to Visual, click Update.

    #1078166

    brianat9
    Member

    I’d somehow missed this. Thanks.

The topic ‘Space not appearing above and below one paragraph, when I publish’ is closed to new replies.