Spam deletion feature/widget

  • Author
    Posts
  • #3290585

    openreel
    Member

    Hi there,
    My blog gets a lot of spams around 1000, more or less, regularly.
    I think nobody wants to read them one by one, and Akismet never fails!
    Its easy to delete them in batch by clicking ‘Empty Spam’. However, WP always gives error (503) when the spam messages are many, and I should repeat the process several times until all are deleted. Annoying. :(
    Do you consider to offer an automated spam deletion widget or option like the ones available for WP.org?
    Thank you for your attention.
    Best

    The blog I need help with is eishaki.wordpress.com.

    #3290889

    Hi openreel,

    I’m glad to hear Akismet is doing its job :) What is the address of the site where you are seeing a 503 error when batch deleting batch comments?

    Does this only happen when deleting large amounts of spam comments? Or even when you are only deleting a few at a time (less than a page in the WP Admin dashboard)?

    Just let me know and we can go from there.

    #3291085

    openreel
    Member

    Hi Emma, (sorry, if misspelled)

    Thank you for your kind attention!

    https://erkanumut.wordpress.com

    This only happens when deleting large amounts of spam comments.

    All the Best,

    Erkan

    #3291246

    supernovia
    Staff

    Thanks Erkan. I’m not terribly surprised if you get that error when deleting huge batches of spam.

    I do have good news though:

    Do you consider to offer an automated spam deletion widget or option like the ones available for WP.org?

    We actually already delete older spam for you automatically. Or at least we normally do that. If that’s not happening for you, would you mind allowing some spam to accumulate, then contacting us here?

    #3297138

    openreel
    Member

    Hi,

    Right now, I have Spam (1,619).

    Thanks!

    Erkan

    (P.S.: I think you have deleted some for me very before first time.)

    #3297210

    Hi Erkan –

    When I look at the spam from here, I only see 10 pending items. Are we looking at 2 different things?

    #3297395

    openreel
    Member

    Hi Liz,

    Yes, because I have started the topic when I was on the blog you looked at. Its pity that we cannot edit that blog link just after we post!

    The one I am talking about: https://erkanumut.wordpress.com

    #3297458

    Thanks! What you’re describing has already been caught by our internal spam filters, which is good, because they’re working. You really don’t need to do anything about it. Every 30 days we automatically delete all of that from the system for you. It won’t affect your site performance in any way.

    If it’s ok with you, I can try and delete a page from my end and see if the error displays.

    It won’t hurt to try the following:

    – use a different browser
    – clear browser cache
    – sign out + back in to WordPress.com

    #3299740

    openreel
    Member

    Hi Liz,

    Thanks!

    Is that what you mean by deleting a spam message already caught from your end?

    #3299885

    Yes. I can try and delete a page of spam that has already been caught by the filter to see if the same error appears.

    #3300039

    openreel
    Member

    Please do so.
    Thanks!

    #3300122

    supernovia
    Staff

    @openreel, sorry, to clarify, the system will automatically delete spam that’s 30 days old. That’s what I’d meant to check on for you, so if that is not working, can you let us know? Right now there aren’t any spam comments that are older than that.

    If you try bulk deleting too many things at once, it’s possible to get a server error. ~1600 was fine, but several thousand can time out.

You must be logged in to reply to this topic.