spammer posting as me on my blog

  • Author
    Posts
  • #1545149

    mjstelly
    Member

    Stop spam posters on my blog. An unauthorized person is spamming posts on my blog impersonating as me. I don’t know how they do it. Although all posts require authorization from me, they’re still getting posted without my approval. I am the only admin on this blog.

    How can I stop these posts?

    The blog I need help with is etmtulsa.wordpress.com.

    #1545213

    auxclass
    Member

    Are they making Posts on your blog or just comments on Posts?

    If they are making Posts – change the password to your blog and email, also make sure Post by email is not enabled.

    If they are making comments, check your comments settings

    Dashboard >> Settings >> Discussion

    #1545215

    mjstelly
    Member

    I didn’t even think to change my password. I think that may have been the issue. I reset it. Let’s see if that makes a difference.

    Thanks.

    #1545216

    justjennifer
    Moderator

    Make sure you also change your email password, as auxclass has suggested.

    #1545219

    auxclass
    Member

    Also double check the Users to your blog to make sure another one has not been added. Remember to check the post by email & disable if it is enabled – and change email password

    #1545295

    mjstelly
    Member

    I’ve changed both the wp and email passwords, and implemented all the other suggestions. I’m still getting the spam post.

    #1545296

    justjennifer
    Moderator

    Thanks for letting us know. This thread has been marked for Staff assistance.

    Please don’t permanently delete the spam posts, but turn them into either Private (which means only you and staff will be able to see it) or as an unpublished Draft. That way Staff will have something to look at when they get to answering this thread.

    Also, probably stating the obvious, but if you are on a shared computer, please make sure you log out of WordPress.com.

    #1545297

    justjennifer
    Moderator

    Looking at Google’s cache of your site’s front page from 2 days ago, there are two posts from November 26th which very much appear to be posts by email. Are you certain you have disabled that feature?

    (Screenshot)

    #1545306

    mjstelly
    Member

    I missed the ‘post by email’ instruction. That was still enabled (don’t remember enabling it, but oh well). I disabled that. Let’s see if that stops the spam.

    Thanks for the support.

    #1545314

    eurello
    Staff

    Hi Michael – That should fix the problem. It looks as if you accidentally subscribed your secret email address to some sort of mailing list (perhaps a cut-and-paste error) and email you were receiving was posting directly to your blog. Let me know if you have any further trouble!

    #1545361

    mjstelly
    Member

    Looks like that resolved the issue. Haven’t received anymore spam posts. I’ll reply here should the problem persist.

    Thanks.

The topic ‘spammer posting as me on my blog’ is closed to new replies.