Need help? Check out our Support site, then


Static front page doesn't have comments section

  1. I have made the about page my static front page. The blog address lands on this page. I have enabled comments on every single page on the blog. However, 'leave a comment' section is missing on the static front page. But, if I try to open the same 'about page' separately like any other page on the site, it shows the comments section. Only the landing page doesn't have the section visible. I would like to have the comments section enabled on the landing page, which is the about page (static). How do I achieve that?

    The blog I need help with is adakshinamurthy.wordpress.com.

  2. Hello there,

    Comments are open on all posts and pages by default. You ought to be able to an enable and disable comments on WordPress.com blogs on this page Dashboard > Settings > Discussion

    That is where you set up defaults for comments and other comment options http://en.support.wordpress.com/settings/discussion-settings/

    You can override the default settings and enable or disable future comments on any individual post or page.
    http://en.support.wordpress.com/enable-disable-comments/

    Important Note: By default, new blogs on WordPress.com will have the Discussion hidden. You can reveal it by clicking on Screen Options http://en.support.wordpress.com/screen-options/ on the top right corner of your Admin page, and checking the box that says Discussion so the module is included. http://en.support.wordpress.com/modules/#list-of-modules

  3. If you do not succeed type modlook into the sidebar tags on this thread for a Staff follow-up. How do I get a Moderator/Staff reply for my question? https://en.support.wordpress.com/getting-help-in-the-forums/#how-do-i-get-a-moderatorstaff-reply-for-my-question Also subscribe to this thread so you are notified when they respond and be patient while waiting. To subscribe look in the sidebar of this thread, find the subscribe to topics link and click it.

  4. Thank you, timethief!
    I had tried all that you have suggested before coming here for help. Like I said, the comments section shows up everywhere expect on the static front page which is my About page. The About page has the comments section enabled and it shows up when I click specifically on the about page. However, it is missing on the landing page. I don't see any Discussion settings for static front page anywhere if at all it is available on my Academecia theme.

  5. Hi sangampoetry,

    However, 'leave a comment' section is missing on the static front page.

    The Academica theme doesn't support comments on any page set as the static front page for your site — which is why the comment area displays if you visit the Ayyaswami Dakshinamurthy page directly. I'd love to give you a workaround but I'm afraid that behaviour is coded into the theme so it can't be changed.

  6. Hi gemmacevans,
    Thank you so much for your response! The theme doesn't support comments on static front page, huh? That sucks! I like this theme. I don't know if there are similar themes available on WP. Can you suggest a few that I can choose from? Thanks!

  7. Hi sangampoetry,

    I don't know if there are similar themes available on WP. Can you suggest a few that I can choose from?

    Sure! These themes are suited to written content and support comments on a static front page:

    If none of those are quite what you are looking for, we have lots more to choose from on this page:

    https://wordpress.com/themes

Topic Closed

This topic has been closed to new replies.

About this Topic