Static Home Page Shows the Latest Blog Post Only

  • Author
    Posts
  • #2161968

    scottamyx
    Member

    I recently mapped my WP blog to my existing domain – amyxmckinsey.com. I also published a new blog post this morning. When I go to the primary domain address above on my mobile phone, instead of displaying the static Home page as set in the Customizer, it shows the latest blog article.

    How do I ensure that amyxmckinsey.com always show the static Home page and not the latest blog post?

    The blog I need help with is amyxmckinsey.com.

    #2162036

    timethief
    Member

    You have two choices.
    (1) All posts on the front page at http://amyxmckinsey.com/
    (2) A static front page and posts on a different page.

    By default the front page of your blog displays all published posts (not pages) in reverse chronological order, with the most recently published post on top. That is for the convenience of your returning visitors.

    However, if you do not want all the posts to show on the front page, then you can create a static front page called for example “Welcome” for your site and a “Blog” page for posts.

    To do that create two pages first http://en.support.wordpress.com/pages/

    After you do that you go to > Settings > Reading and make the designation change and click “save changes”.
    http://en.support.wordpress.com/pages/front-page/

    A static page (select below)
    Front page:
    Posts page:

The topic ‘Static Home Page Shows the Latest Blog Post Only’ is closed to new replies.