Need help? Check out our Support site, then

Stats page won't load

  1. i have not been able to read my stats page for a week now and it just keeps acting like it's uploading but nothing happens...just the rotating circle symbol.

    The blog I need help with is

  2. ME TOO... getting frustrated..

  3. it's been a week or more for me. any solutions?

  4. Are you using an IE9 browser in compatibility mode? If so that makes it render as IE7 and IE7 is not supported.

    Are you using DoNotTrack or Ghostery browser addons? If so, disable them.

    Are you using the secure https:// login? see If not try using it please.

    These are the troubleshooting steps we take whenever any issues like this arise:
    clearing your browser cache and cookies >
    using the browser with all extensions or add-ons disabled
    updating the browser to the latest stable version (not a buggy BETA browser version)
    confirming third party cookies is enabled
    confirming JavaScript is enabled
    confirming Flash is updated and if required installing the latest version of Flash
    resetting your router and modem and rebooting your computer
    then logging in using the secure https:// log-in see
    trying another browser

    If those do not work for you then we need to know
    (1) how you are connecting to the internet and to The way you connect to the internet (mobile, satellite, DSL, dial-up) and to your blog, and how many proxy server jumps etc. it takes to connect can cause problems. There maybe be problems with your ISP and/or with the proxy servers. Also note that the main dashboard isn’t designed to work with touch devices through the tablet and smartphone browsers.

    (2) exactly which browser and version of it are you using. If you don’t know click here to find out >

  5. I haven't been able to view my stats page for nearly two weeks, and don't even get the rotating circle symbol anymore.

  6. @ricefork
    Would you please respond to what I posted above?

  7. I switched to google chrome from IE and my problem is gone.

  8. @jmassery
    Thanks for confirming that it was an IE browser issue in your case. Happy blogging!

Topic Closed

This topic has been closed to new replies.

About this Topic