Stats Plugin Stopped Working: API Problem

  • Author
    Posts
  • #585222

    beforewisdom
    Member

    I guess I am in the same boat as everyone else.

    I self host my own wordpress blog on lunarpages.com ( http://www.beforewisdom.com ). The wordpress.com stats plugin is one of my favorites. A few days ago it stopped working. All I get is this error message:

    <b>Your wordpress.com account beforewisdom is not authorized to view the stats of this blog</b>

    #585223

    Hey can someone help me or tell me where to find support to install coppermine onto my blog!! I’m totally clueless right now :(

    #585224

    hey beforewisdom, I agree about the suggestion that WP gives us some sort of message, because all sorts of conspiracy theories are popping up and their silence is certainly not dispelling them…
    That said, have you written to support at wordpress dot com to tell them you can still not see the stats? they seem to have helped people who wrote them an email.

    #585226

    timethief
    Member

    @katrinakaiffan
    The blog linked to your username is a free blog from and being free hosted by wordpress.COM. What is Coppermine? And what does it have to do with the wordpress.COM stats plugin and or Jetpack?

    Coppermine is a plugin for a photo gallery. It cannot be used on free hosted wordpress.COM blogs because we do not have FTP access to wordpress.COM free hosted blogs and cannot install any plugins into them. There are two different wordpress sites. The differences are stated here > http://support.wordpress.com/com-vs-org/ and in the sticky post at the head of this forum.

    When you have wordpress.COM support issues please start your own threads rather than posting off-topic requests for help into threads on completely unrelated issues. https://en.forums.wordpress.com/?new=1

    #585228

    beforewisdom
    Member

    I may have figured out something that will help some people here.

    I self host my own wordpress blog on lunarpages.com ( http://www.beforewisdom.com ). The wordpress.com stats plugin is one of my favorites. A few days ago it stopped working. All I get is this error message:

    Your wordpress.com account beforewisdom is not authorized to view the stats of this blog.

    To be clear

    I host my own copy of the wordpress software AND I have a wordpress.COM account( with a blog). Whatever change wordpress.COM made, the stats plugin can’t handle it.

    I updated my *existing* wordpress.COM account to have a separate email address from the wordpress blog software installation I host.

    I then created a new wordpress.COM account, without creating a blog there, to get a new API KEY.

    I went into phpMyAdmin, the wp_options table and deleted the information in my stats_option field.

    I relogged in to my blog ( my private installation I host ). It told me that for the stats plugin I needed an api key. I followed the links to my NEW wordpress.COM account ( without a blog ) where it showed me an API KEY. I took the new API KEY and put it in my self-hosted blog.

    No stats yet, but the error messages are gone and a message says its collecting information as well as that it will report it when it has some information.

    I have no idea if I will get my historical stats back.

    Hope this helps.

    #585229

    @timetheif thanks for explaining and I’m sorry for commenting in the wrong area..I didn’t know..again sorry!

    #585231

    I have the same problem. WordPress.com stats stopped working on my self-hosted blog.

    Does anyone else have a dummy account in their wordpress.COM blog list with “www2” as the prefix?

    I do, and I rather suspect all my old stats are in THAT account waiting for someone at wordpress.com to migrate them over.

    So I’d hang tight for a few more days. It might be that wordpress.com rolled out a change (probably relating to the new JetPack plugin) that required that they archive old stats.

    I’ve written jetpack support to inquire and will report back if/when they respond.

    #585232

    raincoaster
    Member

    Please read this thread. It won’t take you long before you find the solution; it’s been posted in the thread several times.

    #585233

    timethief
    Member

    @katrinakaiffan
    Not to worry. We were all new once. :) The next time you need help you will know where to post.

    #585235

    @rain: I’m not sure who you were responding to. If it was to me, I can assure you I’ve read the entire thread and tried everything to no avail. (I also searched Google for about an hour and a half before posting here.) If it was to others, then maybe just indicate to whom you are responding. In either case, detail beyond “read the whole thread” would have been helpful.

    @beforewisdom: you almost certainly will NOT get your old stats back, since you are using an entirely new API.

    #585236

    codefam
    Member

    Is it normal to log on to wordpress.com, and have it redirected RIGHT TO MY DOMAIN WP INTERFACE>? This whole mess smells of datamining to me.

    #585237

    codefam
    Member

    How do I close my wp.com account?

    #585238

    timethief
    Member

    If you purchase a domain name and then domain map a root blog here at wordpress.com to it then that’s the result. In fact it’s what we pay for.
    http://en.support.wordpress.com/domain-mapping/

    If that’s not the case in your case then contact Staff directly using this link. >
    http://en.support.wordpress.com/contact/

    Deleting username accounts is not possible here as those who use the Akismet or wordpress stats need an account to get the API keys. Read this entry for more clarity. > http://en.support.wordpress.com/deleting-accounts/

    #585241

    disiu
    Member

    Ciao,
    sorry for my bad english, a little solution for self hosted blog:

    only if you have shared wordpress.com stats whit other account

    – upload previous version of Wp-Stat (1.8.0)
    – from self hosted wordpress blog go to dashboard >> site stats
    – enter user and pass of accout that shared stats view

    thats all!!

    #585244

    givesuccess
    Member

    I am getting screamed at by my site owners that I admin for. The funny thing is that the Big red eorror box says “The owner of the original key can add users to the access list” How does one add and to what list, where??
    Also now on other sites that use wp.com stats show the blog titles as just a number and the graph and txt totals are way off on the site with wp.com stats “working”.
    Why people seem to be “pushing” Jetpack on us anyways? I onl;y need stats not all the other crap it comes with. Watch it be because of time going ahead 1 hour in USA…lol
    I hope they can fix soon. They should make one place to find info on this prob instead of all over the web. It also to me seems like they are suppressing all the angry replies/comments about it. Everyone I know who uses this plugin is having the same probs as me. So it has to be a wide spread issue.

    #585245

    yakos1
    Member

    Who says this problem is resolved?
    I was told to try jetpack after the shambles that was WordPress.com stats !
    I did do that.
    And its been 3 days now jetpack is once showing one set of stats another time showing about 100 less.
    I think that wordpress are still in big trouble with the stats and Jetpack to-date has not been the answer.
    Please don’t say the problem is resolved unless everyone is happy.

    #585248

    reverendstu
    Member

    The stats plugin is still completely b0rked. The site total bears no relation to the page totals, and the “most read” plugin returns no results.

    #585251

    <AOL>Me Tooo!</AOL>

    Glad I’ve got Woopra going as well.

    #585253

    timethief
    Member

    It’s always a good idea to have two metrics systems running on one’s blog and this situation certainly demonstrates why.

    #585254

    kenpierce
    Member

    I’ve had this issue for about five days now, and am unsure when it started since I was also dealing with a server crash dilemma at my hosting company. Either way, no stats are being shown in my two self hosted blogs of http://piercingmetal.com/wordpress and http://piercingken.com – A support person wrote back only after I installed something called “Jetpack” which would not configure and hence was dumped.

    Like many others here in this thread I get the “does not have permission” error on stats where the Editor is the sole person responsible for the blog. It sucks since I like to monitor what I am getting the most attention for as a writer.

The topic ‘Stats Plugin Stopped Working: API Problem’ is closed to new replies.