stop email notifications for comments on other people's blogs

  • Author
    Posts
  • #883205

    jaw501
    Member

    It’s been several days now since the issue of double comments and comments that you can’t turn off glitches were identified on this forum. Usually, WP is responsive, attentive and helpful. There’s nothing (I can find) about how long it will take to fix this (if in fact it is a fix-able glitch) or any fix we can make ourselves. (Lots of good ideas here, but none of them are precisely the right fix). I’m wondering if there’s a WP person monitoring these, just so we could maybe get a tiny bit more info. Thank you to the wonderful volunteers, but even they have identified this as something WP needs to address.

    #883210

    titabud
    Member

    Hi, this has been mentioned by ajmattic (Staff) in a comment above but those who need step-by-step instructions may find this additionally helpful if you are on the receiving end of the emails and IF you’re also on WordPress.com:

    1. Log in to WordPress.com.

    2. Open this link: https://subscribe.wordpress.com/

    3. You will be directed to a page where all the blog sites and comments you subscribed to are listed. Under the logo and the ‘heading’ WordPress.com, there’s ‘Sites’, ‘Comments’, and ‘Settings’.

    4. Very important: Default view is on ‘Sites but you don’t want to unsubscribe from those so click on ‘Comments.

    5. Check all that you want to unsubscribe from.

    6. Click on the downward arrow beside ‘Bulk Actions‘ on top, choose Unfollow, then Apply. That’s it.

    #883211

    jaw501
    Member

    Titabud: Thank you so much. That was very clear, and (obviously) it solved my immediate issue. Very much appreciated. (You would think we could have ascertained that from some of the previous posts, but it wasn’t obvious to me until your post).

    Meanwhile, I’ll just have to remember to un-check everything I comment on, to avoid endless streams of emails. I do think WP should consider changing that back. It’s like negative option billing.

    Anyway, just thank you very much.

    #883212

    titabud
    Member

    Glad to have helped, @jaw501. :)

    #883216

    wank
    Member

    There have been so many issues with commenting recently that it’s probably a good idea to advise your commenters to use a fake or throwaway email address rather than their real one.

    #883217

    windwhistle
    Member

    So far none of the suggestions here have stopped the flood. Just make it stop, WordPress!! Make it stop!!

    #883218

    ianrobo
    Member

    This really is a very very poor idea from WP. Only just realised the tick was on by default and now I have to remember to untick it. When people have these ideas and refuse to acknowledge the user base hate it I have to ask why ?

    BTW in this forum the option is left unticked

    #883221

    jmmcdowell1
    Member

    @fogsmoviereviews — I know, there’s no perfect solution right now. One blogger (like me) may have few people who sign up for email comments. But another blogger could have many who do. For me, I believe I’d be inconveniencing many more people by leaving the option up. But it may not be the right solution for you or others.

    WordPress has made some wonderful upgrades, even in the 6 months I’ve been blogging. But everyone makes mistakes, and this appears to have been one. I hope they’ll realize this and at least provide us with the individual option to have our blog default to Unchecked!

    #883223

    bubbawheat
    Member

    I am another blogger who does not like this change. Why would I want to get an e-mail every single time I leave a comment telling me that I just left a comment? It’s ridiculous! Please change it! There are dozens of easy ways to track comments on WordPress and this change to spam my e-mail is not wanted at all.

    #883224

    morganrlewis
    Member

    WordPress staff, this needs to be changed. Whether it’s a bug or not, it’s a bad thing, and it’s not proper behavior for the sites.

    Most people don’t want comment subscriptions for every single blog post they reply to. Most don’t want it for any. Not receiving emails for every comment is the normal desire, and should therefore be the normal behavior. This is an easy, obvious case of a behavior that should be “opt in” — and you’ve made it “opt out” instead.

    And considering you don’t have the box below this very thread (“Notify me of followup posts via e-mail” checked by the default, it’s pretty clear you understand that principle here, so why is it now different on our blogs?

    #883225

    conorbofin
    Member

    I don’t want to be a pest but I have to add my voice of discontent to the clamor. Rafts of email about comments. It will stop us commenting. This will lead to less interaction on WordPress. Not the desired outcome, surely? Strangely, the button below is unclicked…
    Best,
    Conor

    #883230

    elise38
    Member

    Putting the burden on readers to opt-out of spamming their email box is unfortunate. Especially in light of the fact that many people are trying to cultivate trust and community for their blogs. I don’t see how spamming them is going to help with this at all. Keeping track of comments/discussions is great but so is freedom of choice. Opting out is aggravating. What happened to ease of use? Opting out is the complete opposite I’m afraid.

    #883232

    pattikuche
    Member

    Funny that on the stats site there is the recommendation to “comment on other blogs etc” in order to drive up site traffic! I comment only because I am interested enough in the post and as much as I might love them, the emails are driving me nuts. I have been into settings, discussion on my own blog and checked that this is not my default position.

    Who thought it was a good idea to have this box ticked on my behalf, I thought that was my choice to do. Not to have to UNDO!

    Tired, cross and cranky . . .

    #883233

    kofykat
    Member

    Same thing is happening here. And I can’t do the uncheck thing because I still want email for comments on my own blog. But not for other blogs that I have commented on. :-(

    #883234

    titabud
    Member

    Hi, @kofykat.

    The Notify me of follow-up comments via email option in your comments box is for your readers. As blog admin, you will still receive emails when readers leave comments on your own blog even when that option is no longer available for them.

    I hope that helps. :)

    (I posted something about this for my own readers and you may want to refer to it: http://wp.me/p1GMx0-1A1 )

    #883238

    After getting back a generic response to a support ticket I submitted on the subject, I’m convinced that WordPress has settled on the moronic opinion that this default is now somehow BETTER.

    Unfortunately, I’ve now had to remove the option to get follow up emails altogther on my blog. Thanks WP! I refuse to email people who forget to uncheck something. Comment replies should not be a booby trapped process.

    I still cant believe WordPress stands behind this, in my year with them, they’ve seemed so savvy up til now. This change is bush league….

    #883241

    cbwentworth
    Member

    I’m starting to receive complaints from my e-mail subscribers, regarding the influx of e-mail in their inboxes. This is not good. :-(

    #883243

    krikitarts
    Member

    PLEASE make it a top priority to fix this problem! No one wants a defalut setting that results in getting flooded with unwanted comments on comments, etc. This is VERLY bad for your membership relations.

    #883245

    vivinfrance
    Member

    How much longer is this farce going to continue? I’ve blogged about it twice, written 2 poems about it, emailed support 3 times, helped innumerable bloggers to change their settings with the retrograde step of removing the options from their own blogs so as not to inundate their friends with spam. Please change it back to how we were, NOW.

    #883250

    gigihawaii
    Member

    I sent one of them to SPAM without opening it first. And that sent them ALL (including ones in the future) to SPAM automatically. No problem anymore because I never read stuff in my spam box.

The topic ‘stop email notifications for comments on other people's blogs’ is closed to new replies.