Stop gallery pictures being used as thumbnail/preview images on social media

  • Author
    Posts
  • #3095888

    I structure my blog posts so that there is a large “cover” image at the start, or near the start, of the posts. When I share links to these posts on social media, this “cover” image is usually displayed as a thumbnail or preview image (e.g. on Twitter Summary Cards, on Google+).

    However, when my posts also contain gallery images, and I try to share the link on social media, it is ALWAYS the first of the gallery images which comes up as the thumbnail/preview, instead of the “cover” image.

    Is there a way to stop this happening? Is there a way to make sure the very first picture in my posts is the image that shows on links on social media, and that gallery images never are?

    And is there a way to do this without having to set the “cover” image as a “featured image”? (The reason I ask is that I want to avoid having pictures showing on the posts page of my website, which they inevitably do when featured images are set).

    The blog I need help with is rebeccaalasdair.com.

    #3096040

    If you are having problems uploading images then the most likely causes are:

    The file size of the image is too large.
    Your connection is slow.
    There is a problem between your computer and the WordPress.com server. (You do not have a direct line here. Your connection will go through any number of hubs before it gets here and one problem along that line could cause a problem.)
    Your storage space is full. You are provided 3GB of free space with your free WordPress.com account, but once full, additional media cannot be added. You can purchase the Space Upgrade in order to gain more space for your site.
    If your image files are large, you may want to optimize the images before you try uploading them.

    To make sure you have a good connection to the server, you can try clearing some of your temporary internet files. See the Browser Issues help page to learn how.

    Filenaming
    It is best to stick to letters and numbers only. If the file name of your image has other characters they will be removed or replaced with the ‘-‘ symbol.

    ↑ Table of Contents ↑
    Color Profiles
    If the colors in your uploaded images appear different from the originals, make sure you are saving your images in sRGB before you upload them. The sRGB color profile will work the best for resized images on the WordPress.com servers. Keep in mind that some sRGB images still may have slight shifts in color when they are resized on the server. If you want to make sure your colors are as close as possible to the original, upload your images in the same dimensions that you’d like to display them on your blog and insert them at full size with no image dimensions.

    sRGB is a standard default color profile for the web and is the most common color space used by web servers today. Check out this explanation on sRGB vs. Adobe RGB for further details on color profiles.

    #3096042

    Thanks, but I can upload pictures just fine. That’s not the problem I’m having.

    #3096043

    welcome :)

    #3096048

    shubhamgmath
    Member

    Hi

    rebeccaalasdair
    Member
    Apr 12, 2018, 3:48 PM

    I structure my blog posts so that there is a large “cover” image at the start, or near the start, of the posts. When I share links to these posts on social media, this “cover” image is usually displayed as a thumbnail or preview image (e.g. on Twitter Summary Cards, on Google+).

    However, when my posts also contain gallery images, and I try to share the link on social media, it is ALWAYS the first of the gallery images which comes up as the thumbnail/preview, instead of the “cover” image.

    I just visited your site and then try to share one of your post on facebook I just saw that header image was displayed as the thumbnail while sharing.

    Is there a way to stop this happening? Is there a way to make sure the very first picture in my posts is the image that shows on links on social media, and that gallery images never are?

    And is there a way to do this without having to set the “cover” image as a “featured image”? (The reason I ask is that I want to avoid having pictures showing on the posts page of my website, which they inevitably do when featured images are set).

    I am tagging this post as “modlook” for staff assistance, please wait for some time they will get back to you on this.

    Hope this helps.

    #3096049

    Interestingly I haven’t had too many issues with Facebook. Twitter and Google+ have been the most uncooperative.

    #3096079

    Hi rebeccaalasdair,

    Is there a way to make sure the very first picture in my posts is the image that shows on links on social media, and that gallery images never are?

    If no featured image is added, the first image from the post will be used instead:

    https://en.support.wordpress.com/publicize/#images-in-publicize

    By default, the Arcade theme doesn’t provide the option to hide featured images but this should be possible with custom CSS (a feature of your Premium plan). Hopefully this will mean the featured image will be shared on social media but it won’t be visible on the Blog page.

    Would you like me to write some CSS to try?

    #3096155

    Thanks for your help gemmacevans! I’m going to stick with the featured images for now and have a bit of a play myself.

    #3096158

    No problem. We’ll be happy to help if you change your mind :)

The topic ‘Stop gallery pictures being used as thumbnail/preview images on social media’ is closed to new replies.