Strange OpenID behaviour with Custom Domain

  • Author
  • #226438


    I was trying to log in to LiveJournal using the OpenID of my blog which is on the custom domain

    When I entered my domain into LiveJournal’s OpenID login box, I was greeted by a message telling me that I hadn’t yet logged into, but I had! I went to the WP admin, and sure enough, I was logged in.

    I checked my cookies, and no cookies had been assigned for the domain (apart from the Google Analytics cookie), but they were there for the domain (which my WP admin for goes to).

    I then visited one of my blog posts on Then, I checked my cookies. I then had the right cookies for!

    So I then logged into LiveJournal via OpenID, same as before, and it worked. Just visiting one of my blog posts fixed it.

    I think it’s because of the JavaScript for the WP admin bar that displays at the top. Because the JavaScript is hosted on, it gets the login cookies. Then, if the parent page doesn’t have the cookies, it copies them to the parent page, thus the reason why it started working after I viewed a post.

    Weird, but might help for someone else who’s having the same problem.



    The joys of having domain mapping and multiple cookies! Thanks for the update Jeremy :)


The topic ‘Strange OpenID behaviour with Custom Domain’ is closed to new replies.