Stripping out paragraph breaks…why?

  • Author
    Posts
  • #24697

    mevetts
    Member

    Hi,

    When writing pages or a post and I hit enter twice so the paragraphs are spaced out, why when I publish it do these extra lines get strippied out and show the paragraphs as if the enter button has been pressed once?

    Sometime I want to hit enter and the shift+enter to add an extra line, this get removed as well!

    I’ve tried turning off the rich text edition, but it does nothing. I also do not have the boxed ticked about WP automatically sorting out invlaid XHTML code.

    Any ideas?

    Many thanks.

    #25128

    mevetts
    Member

    Hmmmm…..

    Got it to work, but only by turning off the rich text editor, stripping out all the code entering all the <br> code, but on the line with no content inserting non-breaking spaces ‘& n b s p ;’ (without the spaces between each of the characters!

    This is a bit tedious.

    #25141

    timethief
    Member

    @mevetts
    Have you tried using a program like Blogdesk http://www.blogdesk.org/en/index.htm

    BlogDesk is totaly free of charge and optimized for the blog systems WordPress, MovableType, Drupal, Serendipity and ExpressionEngine as well as the bloghosters Blogg.de and Twoday.net. As an offline weblog client, BlogDesk lets you comfortably write and effortlessly publish new entries to your blog.

    No need to use those annoying HTML Tags in the WYSIWYG editor. Images can be directly inserted and are automatically uploaded. Even publishing simultaneously to multiple blogs is a matter of a click.

    With the ImageWizard you can not only insert images to your posts – it’s possible to edit them as well (crop, resize, rotate, shadow etc., see Examples). Even Thumbnails can be created – the preview will be shown in the blog and a click on the image will open it in its original size. Linking and uploading those images is automatically done by BlogDesk.

    #25168

    drmike
    Member

    A quick search would have saved you some time. :)

    #25205

    BlogDesk looks pretty neat. Will try it out and see if I can finally add tables and centre some of my headings…

    #25341

    This really doesn’t answer the question though. Why does WP insist on stripping html codes? Especially when they give you a “code” tab. It’s the most bizarre thing I’ve ever seen.

    #25342

    sulz
    Member

    i can get the <br> tag to stick after trying several times on the editor, though it gets messed up if i edit it again.

    #25343

    I find those line breaks a bit of a problem as well. My work-around is to use a small bit html in the “code” section. ‘p’ ‘/p’ I had noticed that a lot of html tags which are normally left open are changed into “/” closing tags in the WP wysigyg editor so I tried it and found it works. I type it out once, ctrl C it then paste it through the entry as needed.

    #25344

    atthe404
    Member

    One of the issues here – and I do have some sympathy with the WordPress developers – is that paragraph breaks dimensions are normally set in the CSS. Further the <br /> tag is pretty much out of use because one it is butt ugly, and two a break is inherent in /p. So folks who want double spaced paras are asking the editor to do something which is inconsistent and arguably that they should not be doing at all. When many of us switched to Web Standards for developing sites getting rid of the br tag (and the font styling in table cells) was the happiest day of our lives. :) The proper solution is unfortunately only available on the CSS upgrade. There you could add an extra class for a double break.
    That is the semantic solution. Not a lot of break tags cluttering up your markup. :)

    #25345

    kimik0
    Member

    ?? I don’t understand the problem. If I put one enter in the editor, I get a linebreak (text begins on a new line). If I put in two enters, I get a paragraph break (one empty line between them). I only use <p> and <br> tags on the rare occasions I need to add attributes to them.

    Is it perhaps the theme/CSS you’re using? Or do I not have the problem because I’ve disabled the (IMO annoying and messy) visual editor?

    If you need more space between paragraphs than one line, you’ll have to add style attributes to them and specify top or bottom margins.

    #25346

    mark
    Staff

    You can check the page source here:
    http://faq.wordpress.com/2006/07/06/how-do-i-page-jump/

    #25347

    tilleysong
    Member

    I have pretty much the opposite problem!!! In the editor, I press enter once and it goes down two line spaces. IT IS INCREDIBLY FRUSTRATING. I have tried pasting from Word instead, editing in the Code editor instead, using <br > instead of hitting enter, but no. Nothing fixes it.

    #25348

    raincoaster
    Member

    It’s your template. It will always do that as the default. To override it, hold down the Shift key when you hit Enter.

    #25349

    tilleysong
    Member

    Crimeny. Thankyou so much. My template? You mean “Kubrick”? Which ones will NOT do that?

    #25350

    raincoaster
    Member

    I don’t know. Check out http://www.internetducttape.com because he’s done some theme reviews there.

The topic ‘Stripping out paragraph breaks…why?’ is closed to new replies.