subscribing and unsubscribing. changing messages to the subscriber.

  • Author
    Posts
  • #2015095

    my theme is Twenty Twelve with CSS.
    Oh No! I’m so upset. It’s now published. I put the Follow button up (renamed “subscribe”) and all hell breaks loose.
    1. my brother writes “not clear what to do with the WordPress screen that comes up when you cliick on Subscribe. Very ambiguus as to what the options are. I just want to receive your updates–nothing more. Try it yourself and read what they’re asking.” Please – what DOES come up? I can’t tell because I am already subscribed (as admin and also under “X” … see 2)
    2. As a test, I used another eMail account, X – I “subscribed” using X. Now I want to “unsubscribe” as X, but there’s no way to do it. how does X unsubscribe herself? How does the poor subscriber out there unsubscribe. I don’t see a way. If I press “subscribe” (because there’s no other button”) the canned response is “You are already a subscriber to this site”. Yes, but how does the subscriber unsubscribe?
    Oh misery ….

    The blog I need help with is proustmatters.com.

    #2015236

    I’m talking about the BLOG widget which I placed in the sidebar.
    OK. I’ve spent 2 days learning how the conversation between the blog widget and the subscriber works. (Sorry – I’m a hopeless newbie in this stuff.) Helpful was http://en.support.wordpress.com/widgets/follow-blog-widget/
    Please forget (and forgive) the previous #1 and #2. I understand now. Allow me to change my questions in this area.
    1. (new) A non-follower, non-WP user gets this message after pressing the “follow” button: “Thank you for subscribing! You’ll get an eMail with a link to confirm …. etc.” The problem in my site is that the message appears twice – once in the widget area itself and also below in the right hand corner. What am I doing wrong? How do I suppress the right hand corner … or deal with this confusing duplication?
    2. (new) To a follower, the message “You are following this blog (manage)” where “manage” is a hyperlink (to Manage Subscriptions) appears in the widget area. How do I change this message to be “You are subscribed to this site. If you would like to manage your subscription, press here” where “press here” is a hyperlink to Manage Subscriptions.

    Observation: WP is not consistent in its use of the the terms “follow” and “subscribe”. Sometimes it uses “subscribe” (as in #1) and sometimes “follow” (as in #2) and in documentation as well. (I’m just mentioning, not screaming.)

    #2015237

    What’s going on? I now notice another, different message in the widget area “Congrats, you’re subscribed! You’ll get an email with the details of your subscription and an unsubscribe link…”
    This conveys the same response as #1 above, but why these two different messages. (One says “Thank you for subscribing! …; the other says “Congrats, you’re subscribed!) Where are these two responses coming from? Fog is settling in again. How do I change it? (I rarely use exclamation marks – it’s a matter of taste.)

    #2015380

    Hang in there, I’m pretty sure I can help change the “You are following…” for logged in users message using CSS. Let me work on it a bit for you.

    #2015381

    Hmmm, the software is not giving a different class or ID for the subscribe message for subscribed users so I can’t just change the “You are following this blog (manage)” without changing it everywhere.

    The follow button at lower right, when activated, and the widget produce the same result, so I would suggest using only one of them. Right now I’m seeing you have the follow button at bottom right deactivated.

    #2015382

    Thank you sacredpath. This is exactly what was needed. Wish I had understood what I was doing earlier! I didn’t understand from the documentation that ticking the option in Settings>Reading would ignite the button in the lower right (in addition to my widget). One explanatory sentence in the “how to” doc would have helped me lot. Also helpful would have been consistency is using either the term “subscribe” or “follow” in various places! (Not screaming here … just trying to help.)
    On the other issue – of the difficulty of changing the messages that come back from WP into the widget area … OK. I can easily live with that. I’m very happy to have gotten rid of the duplication (i.e. the follow widget and the other, ticked button)– that caused me so much confusion!
    Thank you, thank you.

    #2015383

    @proustmatters, I’m heading over to that support document right now and will work out a clarification on that. Many thanks for bringing that to our attention. And, you are welcome.

    #2015384

    @proustmatters, I have updated the Follow Blog widget page and also the Settings > Reading page.

    Again, many thanks for bringing this to our attention.

The topic ‘subscribing and unsubscribing. changing messages to the subscriber.’ is closed to new replies.