Subscriptions: Preventing certain posts from being emailed

  • Author
  • #596431

    Hi, how to I keep certain posts from being emailed to my subscribers? My blog features a main post each day (which all the subscribers want) but also often features a number of smaller posts afterward (which many subscribers do not want, since it fills up their email boxes).

    How do I allow for email subscriptions, but designate a post to NOT get sent to subscribers? It seems like a pretty basic functionality, but for the life of me I can’t figure how to do it.


    The blog I need help with is



    I don’t think it’s a basic function: in fact, in five years here, I’ve never heard a request for it. What you can do is rather involved, but it does work: make those posts as Private, then after they’ve gone life, edit and set them as Public.


    Hi raincoaster – does that work for pages too?

    Many thanks.



    I don’t know if this works with Pages. This is the thread we have bookmarked. >


    Thanks very much, timethief.


    Just in case anyone would like to know: as far as I can tell, it does work for pages. I tried one page as a test, and one for real – worked both times.



    Wow! I’m so happy to hear that it works on Pages too. Thanks for returning and sharing that news with us. Bookmarking this thread too. :)


    This is a very useful thing to know, sometime when I need it! An ingenious way to figure it out, raincoaster, even though it’s not a basic function.



    This doesn’t work for posts. I would like the same functionality – to occasionally make a new post but not auto-trigger my subscribers. But in my tests, subscribers are emailed as soon as you go back into the post and change the settings from “private” to public. It may work if you mark the ENTIRE SITE private (as the hyperlinked forum indicates) but that seems like a lot of trouble …

    And, correct me if I’m wrong, but simple page updates don’t trigger subscription alerts. Only newly published posts …



    We can’t comment because you haven’t provided the URL of the blog you’re talking about.


    Sorry if I am misleading anyone here. I can only say that it seemed to work for me…I stand to be corrected.



    So, as I it understand it; presently there is no enable/disable switch to this function or the ability to remove subscribers from the list ala: Dashboard > Site Stats > Total Subscriptions & Shares > Site Subscriptions > Email Subscribers(xxx) or even remove/uninstall the function entirely.
    I will try the private/public switching suggested previously.
    I’m glad I found this forum lest I continued to chase this problem.
    Thank you,

The topic ‘Subscriptions: Preventing certain posts from being emailed’ is closed to new replies.