Suddenly unable to add html links to articles

  • Author
  • #1025252

    When I attempt to add an html link, I go through the routine:
    1) copy the html link
    2) highlight the words that I would like to add the link to in my article
    3) click the insert/edit link button on the wordpress toolbar
    4) paste the link I copied and click the ‘add link’ button

    This has worked a hundred thousand times. But suddenly when I click that ‘add link’ button the link does NOT get added and I get kicked out of the article to the dashboard.

    If I go to the text version (rather than the ‘visual’ format) the only tools that are available to me are to either upload/insert media (i.e. pictures or videos) or add a poll.

    Can someone help me through this?

    The blog I need help with is


    I also just discovered I am also unable to respond to comments.

    And on the comments section, there are no tools available (such as being able to insert links or bold or add italics).



    What browser and version are you using?

    Have you tried the Cookie Dance?

    What exact link are you trying to ad?



    Thanks for responding.

    I’m using IE 9. I clear my cache/cookies etc. after every single session and even during every browsing session. But I tried it again and restarted the computer. That does not seem to be my issue.

    One thing I DID do yesterday which certainly could be related is I upgraded my router (to a Netgear N600).

    I can’t add ANY link without getting kicked out of my article to my dashboard; and I can’t post replies to comments. Nor do I have any tools available on my comment form.



    I have exactly the same problem, also started yesterday with IE9. The only difference is that I have not made any chages to my hardware set-up.

    I have also tried clearing cookies and restarting, which made no difference.

    I have been trying to link to old articles on my blog, for instance the last one I tried was:

    The other thing that has changed is that I can no longer access the comment list through the notification icon. I currently have two notifictions showing (links I created in the text page of the post editor), and I can’t access the list by clicking on the icon.

    As noted above, I can create links on the text page, but if I try on the graphics page I get kicked out immediately, and lose any unsaved data.



    Two other points:

    If I click on the Add Media icon, nothing happens.

    If I copy a hyperlink (i.e. copy the displayed text, not the actual address), and paste that directly into the post editor “visual” page, that works OK.



    I have exactly the same problem, also started yesterday with IE9.

    If you are running IE9 in compatibility mode that means it renders as IE7 and IE7 is not supported. See here >



    Thanks timethief, that seems to have fixed it! (at least for me).

    I don’t know why IE was in compatability mode in the first place, but now it’s not everything seems to be working OK.



    Hooray! That’s great news. Thanks for letting us know it worked for you.


    Wow, timethief, you earned yourself a twofer!

    I initially misunderstood and assumed you were referring to a guy who had IE7 but was trying to be “compatible” with IE9, whereas I’m running IE9.

    But when I clicked on your link I saw the “fix” to deactivate compatibility and when I did it suddenly all my tools came back and I was able to post a response to a comment.

    Thanks a LOT for that easy fix.

    I was assuming I probably had some kind of port that wordpress wanted open that my router wasn’t accessing.

    Great job!

The topic ‘Suddenly unable to add html links to articles’ is closed to new replies.