Need help? Check out our Support site, then

Switch from wp to godaddy: images gone, authors uncredited

  1. I recently switched from to godaddy for a webhost. I exported my xml file and imported it to the new theme. Unfortunately the images are no longer in our media folder so I have to go through 150+ posts individually and upload a featured image. Also all posts are now being attributed to me, but I have over a dozen contributors/authors/editors. Also my name is showing up as my screen name instead of my display name, which is definitely not what I want.

    How can I fix this? Do I need to download my database or something? How? Is that even still an option? Is there a way to fix it some other way? GoDaddy support is not helpful on this front because it's not their software. I need help.

    The blog I need help with is

  2. Hello Angel,

    For security reasons we do not allow users to download database files. However, I can give you more information about how the import process works. We have also documented this here: provides help on how to import your blog here:

    When you import the blog into your self-hosted account you are given the option to to map each contributors post to a new author. You will need to create these users prior to importing the content. It is best to create these users before importing the site.

    Your username/account name is not linked between and your installation. You will need to set your user's display settings to match your preferences over at GoDaddy.

    Sorry to hear you are having trouble with the featured images. Without seeing your import file I unfortunately can't tell you if something is wrong with the featured images. It is possible this is due to a hosting restriction or a theme related issue. Are you using the same theme?

    I hope this helps and let us know if you have any other questions.

Topic Closed

This topic has been closed to new replies.

About this Topic